kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "huxihx (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-6336) when using assign() with kafka consumer the KafkaConsumerGroup command doesnt show those consumers
Date Mon, 11 Dec 2017 03:19:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-6336?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16285474#comment-16285474
] 

huxihx commented on KAFKA-6336:
-------------------------------

Actually, `listGroups` protocol does return the user-assigned groups but ConsumerGroupCommand
filters them out due to they are not of 'consumer' type. I am not sure if this inconsistency
deserves a bug. However, on my test environment (I am using trunk), ConsumerGroupCommand describe
is able to show the lag for such groups. What's the version in your case?

> when using assign() with kafka consumer the KafkaConsumerGroup command doesnt show those
consumers
> --------------------------------------------------------------------------------------------------
>
>                 Key: KAFKA-6336
>                 URL: https://issues.apache.org/jira/browse/KAFKA-6336
>             Project: Kafka
>          Issue Type: Bug
>            Reporter: Neerja Khattar
>
> The issue is when using assign rather than subscribe for kafka consumers commit not able
to get the lag using ConsumerGroup command. It doesnt even list those groups.
> JMX tool also doesnt show lag properly.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message