kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-6238) Issues with protocol version when applying a rolling upgrade to 1.0.0
Date Thu, 23 Nov 2017 14:49:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-6238?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16264421#comment-16264421
] 

ASF GitHub Bot commented on KAFKA-6238:
---------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/kafka/pull/4256


> Issues with protocol version when applying a rolling upgrade to 1.0.0
> ---------------------------------------------------------------------
>
>                 Key: KAFKA-6238
>                 URL: https://issues.apache.org/jira/browse/KAFKA-6238
>             Project: Kafka
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 1.0.0
>            Reporter: Diego Louzán
>            Assignee: Jason Gustafson
>
> Hello,
> I am trying to perform a rolling upgrade from 0.10.0.1 to 1.0.0, and according to the
instructions in the documentation, I should only have to upgrade the "inter.broker.protocol.version"
parameter in the first step. But after setting the value to "0.10.0" or "0.10.0.1" (tried
both), the broker refuses to start with the following error:
> {code}
> [2017-11-20 08:28:46,620] FATAL  (kafka.Kafka$)
> java.lang.IllegalArgumentException: requirement failed: log.message.format.version 1.0-IV0
cannot be used when inter.broker.protocol.version is set to 0.10.0.1
>         at scala.Predef$.require(Predef.scala:224)
>         at kafka.server.KafkaConfig.validateValues(KafkaConfig.scala:1205)
>         at kafka.server.KafkaConfig.<init>(KafkaConfig.scala:1170)
>         at kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:881)
>         at kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:878)
>         at kafka.server.KafkaServerStartable$.fromProps(KafkaServerStartable.scala:28)
>         at kafka.Kafka$.main(Kafka.scala:82)
>         at kafka.Kafka.main(Kafka.scala)
> {code}
> I checked the instructions for rolling upgrades to previous versions (namely 0.11.0.0),
and in here it's stated that is also needed to upgrade the "log.message.format.version" parameter
in two stages. I have tried that and the upgrade worked. It seems it still applies to version
1.0.0, so I'm not sure if this is wrong documentation, or an actual issue with kafka since
it should work as stated in the docs.
> Regards,
> Diego Louzán



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message