kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "huxihx (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (KAFKA-6224) Can not build Kafka 1.0.0 with gradle 3.2.1
Date Fri, 17 Nov 2017 08:52:01 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-6224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16256668#comment-16256668
] 

huxihx edited comment on KAFKA-6224 at 11/17/17 8:51 AM:
---------------------------------------------------------

Seems the valid property name should be `scalaVersion` in build.gradle instead of `scala_version`.


was (Author: huxi_2b):
Seems the valid property name should be ``scalaVersion` in build.gradle instead of `scala_version`.

> Can not build Kafka 1.0.0 with gradle 3.2.1
> -------------------------------------------
>
>                 Key: KAFKA-6224
>                 URL: https://issues.apache.org/jira/browse/KAFKA-6224
>             Project: Kafka
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.0.0
>         Environment: Ubuntu 17.10
>            Reporter: Chao Ren
>            Priority: Trivial
>
> Trying to play around with Kafka on a brand new machine with Ubutun 17.10 installed.
> When building, got the following error, I do have Gradle 3.2.1 installed. definitely
no need to upgrade, should I downgrade?
> ```
> chaoren@chaoren:~/code/kafka-1.0.0-src$ ./gradlew jar -Pscala_version=2.11.11
> To honour the JVM settings for this build a new JVM will be forked. Please consider using
the daemon: https://docs.gradle.org/2.13/userguide/gradle_daemon.html.
> Building project 'core' with Scala version 2.11.11
> FAILURE: Build failed with an exception.
> * Where:
> Build file '/home/chaoren/code/kafka-1.0.0-src/build.gradle' line: 963
> * What went wrong:
> A problem occurred evaluating root project 'kafka-1.0.0-src'.
> > Failed to apply plugin [class 'com.github.jengelman.gradle.plugins.shadow.ShadowBasePlugin']
>    > This version of Shadow supports Gradle 3.0+ only. Please upgrade.
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or --debug option
to get more log output.
> BUILD FAILED
> Total time: 6.186 secs
> chaoren@chaoren:~/code/kafka-1.0.0-src$ gradle -version
> ------------------------------------------------------------
> Gradle 3.2.1
> ------------------------------------------------------------
> Build time:   2012-12-21 00:00:00 UTC
> Revision:     none
> Groovy:       2.4.8
> Ant:          Apache Ant(TM) version 1.9.9 compiled on June 29 2017
> JVM:          1.8.0_151 (Oracle Corporation 25.151-b12)
> OS:           Linux 4.13.0-16-generic amd64
> ```



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message