kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KAFKA-6210) IllegalArgumentException if 1.0.0 is used for inter.broker.protocol.version or log.message.format.version
Date Wed, 15 Nov 2017 10:05:00 GMT
Ismael Juma created KAFKA-6210:
----------------------------------

             Summary: IllegalArgumentException if 1.0.0 is used for inter.broker.protocol.version
or log.message.format.version
                 Key: KAFKA-6210
                 URL: https://issues.apache.org/jira/browse/KAFKA-6210
             Project: Kafka
          Issue Type: Bug
    Affects Versions: 1.0.0
            Reporter: Ismael Juma
            Assignee: Ismael Juma
            Priority: Critical
             Fix For: 1.1.0, 1.0.1


The workaround is trivial (use 1.0), but this is sure to trip many users. Also, if you have
automatic restarts on crashes, it may not be obvious what's going on. Reported by Brett Rahn.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message