kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-5993) Kafka Admin Client throws a warning for sasl.jaas.config
Date Wed, 04 Oct 2017 06:35:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-5993?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16190878#comment-16190878
] 

Ismael Juma commented on KAFKA-5993:
------------------------------------

The warning happens because you're using PLAINTEXT. If you use SASL., the warning will not
be there.

> Kafka Admin Client throws a warning for sasl.jaas.config
> --------------------------------------------------------
>
>                 Key: KAFKA-5993
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5993
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.11.0.1
>            Reporter: Stephane Maarek
>
> Kafka Admin Client does not support basic security configurations, such as "sasl.jaas.config".
> Therefore it makes it impossible to use against a secure cluster
> ```
> 14:12:12.948 [main] WARN  org.apache.kafka.clients.admin.AdminClientConfig - The configuration
'sasl.jaas.config' was supplied but isn't a known config.
> ```



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message