kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KAFKA-2607) Review `Time` interface and its usage
Date Mon, 30 Oct 2017 11:55:00 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-2607?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ismael Juma updated KAFKA-2607:
-------------------------------
    Affects Version/s:     (was: 0.8.2.2)
                       1.0.0
                       0.11.0.0

> Review `Time` interface and its usage
> -------------------------------------
>
>                 Key: KAFKA-2607
>                 URL: https://issues.apache.org/jira/browse/KAFKA-2607
>             Project: Kafka
>          Issue Type: Improvement
>    Affects Versions: 0.11.0.0, 1.0.0
>            Reporter: Ismael Juma
>              Labels: newbie
>
> Two of `Time` interface's methods are `milliseconds` and `nanoseconds` which are implemented
in `SystemTime` as follows:
> {code}
>     @Override
>     public long milliseconds() {
>         return System.currentTimeMillis();
>     }
>     @Override
>     public long nanoseconds() {
>         return System.nanoTime();
>     }
> {code}
> The issue with this interface is that it makes it seem that the difference is about the
unit (`ms` versus `ns`) whereas it's much more than that:
> https://blogs.oracle.com/dholmes/entry/inside_the_hotspot_vm_clocks
> We should probably change the names of the methods and review our usage to see if we're
using the right one in the various places.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message