kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stevo Slavic (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-5977) Upgrade RocksDB dependency to legally acceptable version
Date Tue, 26 Sep 2017 09:54:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-5977?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16180560#comment-16180560
] 

Stevo Slavic commented on KAFKA-5977:
-------------------------------------

Not sure is this considered as duplicate of KAFKA-5576 but it's at least related to it.

> Upgrade RocksDB dependency to legally acceptable version
> --------------------------------------------------------
>
>                 Key: KAFKA-5977
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5977
>             Project: Kafka
>          Issue Type: Task
>          Components: streams
>    Affects Versions: 0.10.0.0
>            Reporter: Stevo Slavic
>            Priority: Critical
>             Fix For: 1.0.0
>
>
> RocksDB 5.5.5+ seems to be legally acceptable. For more info see
> - https://issues.apache.org/jira/browse/LEGAL-303 and
> - https://www.apache.org/legal/resolved.html#category-x
> Even latest trunk of Apache Kafka depends on older RocksDB https://github.com/apache/kafka/blob/trunk/gradle/dependencies.gradle#L67
> If I'm not mistaken, this makes all current Apache Kafka 0.10+ releases not legally acceptable
Apache products.
> Please consider upgrading the dependency. If possible please include the change in Apache
Kafka 1.0.0 release, if not also in patch releases of older still supported 0.x Apache Kafka
branches.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message