kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KAFKA-5960) Producer uses unsupported ProduceRequest version against older brokers
Date Mon, 25 Sep 2017 23:26:03 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-5960?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ismael Juma resolved KAFKA-5960.
--------------------------------
    Resolution: Fixed

> Producer uses unsupported ProduceRequest version against older brokers
> ----------------------------------------------------------------------
>
>                 Key: KAFKA-5960
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5960
>             Project: Kafka
>          Issue Type: Bug
>          Components: producer 
>            Reporter: Jason Gustafson
>            Assignee: Jason Gustafson
>            Priority: Blocker
>             Fix For: 1.0.0
>
>
> Reported recently errors from a trunk producer on an 0.11.0.0 broker:
> {code}
> org.apache.kafka.common.errors.UnsupportedVersionException: The broker does not support
the requested version 5 for api PRODUCE. Supported versions are 0 to 3.
> {code}
> This is likely a regression introduced in KAFKA-5793. We should be using the latest version
that the broker supports.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message