kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Seweryn Habdank-Wojewodzki (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (KAFKA-4316) Kafka Streams 0.10.0.1 does not run on Windows x64
Date Tue, 01 Aug 2017 14:37:00 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-4316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Seweryn Habdank-Wojewodzki closed KAFKA-4316.
---------------------------------------------

> Kafka Streams 0.10.0.1 does not run on Windows x64
> --------------------------------------------------
>
>                 Key: KAFKA-4316
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4316
>             Project: Kafka
>          Issue Type: Bug
>          Components: streams
>    Affects Versions: 0.10.0.1
>            Reporter: Seweryn Habdank-Wojewodzki
>
> We had encountered the problem that starting application with Kafka Streams 0.10.0.1
leads to runtime exception, that rocksdb DLL is missing on the Windows x64 machine. 
> Part of the stacktrace:
> {code}
> Caused by: java.lang.RuntimeException: librocksdbjni-win64.dll was not found inside JAR.
> at org.rocksdb.NativeLibraryLoader.loadLibraryFromJarToTemp(NativeLibraryLoader.java:106)
> {code}
> It is true, as Kafka 0.10.0.1 uses RocksDB 4.8.0. This RocksDB release has broken Java
API. 
> See: 
> https://github.com/facebook/rocksdb/issues/1177
> https://github.com/facebook/rocksdb/issues/1302
> This critical (for Windows) bug was fixed in RocksDB 4.9.0.
> Please update Kafka gradle\dependencies.gradle to use at least 4.9.0:
> So the line shall be rocksDB: "4.9.0".
> I had tested some basic functionality with Kafka Streams with RocksDB 4.11.2 and it was
promissing and definitely the bug was away.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message