kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manikumar (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KAFKA-2897) Class NIOServerCnxn$Factory not found due to mismatch in dependencies
Date Thu, 31 Aug 2017 19:32:01 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-2897?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Manikumar resolved KAFKA-2897.
------------------------------
    Resolution: Won't Fix

Closing inactive issue. Pl reopen if you think the issue still exists

> Class NIOServerCnxn$Factory not found due to mismatch in dependencies
> ---------------------------------------------------------------------
>
>                 Key: KAFKA-2897
>                 URL: https://issues.apache.org/jira/browse/KAFKA-2897
>             Project: Kafka
>          Issue Type: Bug
>            Reporter: Yuval Steinberg
>            Priority: Trivial
>
> It seems that there is a mismatch between zookeeper & zkclient in kafka pom.xml causes
this error upon initialization:
> The pom file (e.g. of kafka_2.10:0.8.2.1) requires zookeeper:3.4.6 & zkclient:0.3,
However:
> * While zookeeper:3.3.x had a class NIOServerCnxn$Factory, in 3.4.x it became an independent
class (NIOServerCnxnFactory)
> * ZkServer class of zkclient:0.3 is still using (importing) NIOServerCnxn.Factory and
only in 0.5 changes to use NIOServerCnxnFactory.
> It seems that the version of zkclient in the pom file should be updated



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message