kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-5585) Failover in a replicated Cluster does not work
Date Wed, 12 Jul 2017 12:13:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-5585?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16083883#comment-16083883
] 

Ismael Juma commented on KAFKA-5585:
------------------------------------

Thanks for the report. Can you provide more details? We have system tests for these kind of
scenarios and they are passing. More concretely, it would be useful to have more details regarding
the producer config, consumer config, code used to produce and consume, log messages.

> Failover in a replicated Cluster does not work
> ----------------------------------------------
>
>                 Key: KAFKA-5585
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5585
>             Project: Kafka
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.11.0.0
>         Environment: Linux, Mac OSX
>            Reporter: Thomas Bayer
>
> Failover does not work in a cluster with 3 nodes and a replicated topic with factor 3.
> You can reproduce it als follows: Setup 3 Kafka Nodes and 1 Zookeeper. Than create a
topic with factor 3. Start a consumer. Stop a node. Write to the topic. Now you get warnings
that the client can not connect to a broker. The consumer does not receive any messages.
> The same setup works like a charm with 0.10.2.1.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message