kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Andre Pearce (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-5537) Subscribe Earliest is not working as in 0.10.2.1
Date Fri, 30 Jun 2017 22:21:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-5537?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16070794#comment-16070794
] 

Michael Andre Pearce commented on KAFKA-5537:
---------------------------------------------

very interestingly we've been reducing down the setting "group.initial.rebalance.delay.ms"
from 3000 incrementally in jumps of 500, and found at 1000 everything starts working, this
would suggest the default value that is used/proposed in the KIP is possible clashing with
another default value (possibly some other timeout/time delay). 

> Subscribe Earliest is not working as in 0.10.2.1
> ------------------------------------------------
>
>                 Key: KAFKA-5537
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5537
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.11.0.0
>            Reporter: Michael Andre Pearce
>            Priority: Critical
>         Attachments: kafka_0.10.2.1.log, kafka_0.11.0.0.log, KafkaSub.java, KafkaSubLatest.java
>
>
> We have seen issue with subscription where auto offset when set to earliest (and also
latest) does not behave the same as in 0.10.2.1 release.
> We have managed to create a repeatable test for this, which passes when pointing to 0.10.2.1
broker.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message