kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin McCabe" <cmcc...@apache.org>
Subject Re: [DISCUSS] KIP-522: Update BrokerApiVersionsCommand to use AdminClient
Date Wed, 18 Sep 2019 19:43:27 GMT
Hi Mickael,

Just to give you the context, this is something that's been discussed several times.

Check out https://issues.apache.org/jira/browse/KAFKA-5214 and https://issues.apache.org/jira/browse/KAFKA-5723
, as well as this pull request: https://github.com/apache/kafka/pull/3012

I think there was some concern that having a public API that returned API version information
would encourage people to write code that only worked against specific broker versions.  I
remember Ismael and Jay expressed this concern, though I can't find the email threads now...

best,
Colin


On Mon, Sep 16, 2019, at 02:39, Mickael Maison wrote:
> Hi all,
> 
> I've created a KIP to add listApiVersions support to the AdminClient.
> This will allow us to update the BrokerApiVersionsCommand tool and
> more importantly allow users to detect API support and build flexible
> client applications:
> https://cwiki.apache.org/confluence/display/KAFKA/KIP-522%3A+Update+BrokerApiVersionsCommand+to+use+AdminClient
> 
> As always, feedback and comments are welcome!
> Thanks
>

Mime
View raw message