kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias J. Sax" <matth...@confluent.io>
Subject Re: [DISCUSS] KIP-488: Clean up Sum,Count,Total Metrics
Date Thu, 11 Jul 2019 18:25:01 GMT
Thanks for the KIP. Overall LGTM.

The only though I have is, if we may want to use `TotalSum` and
`TotalCount` instead of `CumulativeSum/Count` as names?


-Matthias


On 7/11/19 9:31 AM, John Roesler wrote:
> Hi Kafka devs,
> 
> I'd like to propose KIP-488 as a minor cleanup of some of our metric
> implementations.
> 
> KIP-488: https://cwiki.apache.org/confluence/x/kkAyBw
> 
> Over time, iterative updates to these metrics has resulted in a pretty
> confusing little collection of classes, and I've personally been
> involved in three separate moderately time-consuming iterations of me
> or someone else trying to work out which metrics are available, and
> which ones are desired for a given use case. One of these was actually
> a long-running bug in Kafka Streams' metrics, so not only has this
> confusion been a time sink, but it has also led to bugs.
> 
> I'm hoping this change won't be too controversial.
> 
> Thanks,
> -John
> 


Mime
View raw message