kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Long (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KAFKA-7674) Quick Start Guide steps for managing topics do not work
Date Mon, 26 Nov 2018 16:33:00 GMT
Nathan Long created KAFKA-7674:
----------------------------------

             Summary: Quick Start Guide steps for managing topics do not work
                 Key: KAFKA-7674
                 URL: https://issues.apache.org/jira/browse/KAFKA-7674
             Project: Kafka
          Issue Type: Bug
          Components: documentation
    Affects Versions: 2.1.0
         Environment: MacOS 10.13.6
            Reporter: Nathan Long


I'm following the [Apache Kafka Quick Start Guide](https://kafka.apache.org/quickstart) exactly,
using [the release linked at the top](https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.0/kafka_2.11-2.0.0.tgz),
which is versioned as "kafka_2.11-2.0.0.tgz".

At "Step 3: Create a Topic", it says to run this to create a topic:

    bin/kafka-topics.sh --create --zookeeper localhost:2181 \
      --replication-factor 1 --partitions 1 --topic test

The next step is to list the existing topics:

    bin/kafka-topics.sh --list --zookeeper localhost:2181

The documentation shows that `test` should be listed.

The list command returns no output for me. I'm using the default configuration with `log.dirs=/tmp/kafka-logs`,
and looking in that directory, I see no change when I run the command above to create a topic.

When I publish the first message to the topic, I see it fail to send the message, then successfully
retry after the topic is auto-created. I'm then able to see the message when I run the console
consumer:

    bin/kafka-console-consumer.sh --bootstrap-server \
      localhost:9092 --topic test --from-beginning

But even though the topic now clearly exists, when I list topics, it still finds nothing:

    bin/kafka-topics.sh --list --zookeeper localhost:2181

I don't know if this is a documentation problem or a bug, but I get no errors when running
any of these commands, it seems like a bug.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message