kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KAFKA-7307) Upgrade EasyMock for Java 11 support
Date Wed, 10 Oct 2018 14:16:00 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-7307?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ismael Juma resolved KAFKA-7307.
--------------------------------
    Resolution: Not A Problem

We migrated to mockito with full Java 11 support in the clients module (KAFKA-7439) and updated
a few tests elsewhere (https://github.com/apache/kafka/pull/5771) to work with Java 11 by
various means. As such, we don't need a new version of EasyMock for Java 11 support.

> Upgrade EasyMock for Java 11 support
> ------------------------------------
>
>                 Key: KAFKA-7307
>                 URL: https://issues.apache.org/jira/browse/KAFKA-7307
>             Project: Kafka
>          Issue Type: Sub-task
>          Components: packaging
>            Reporter: Ismael Juma
>            Assignee: Ismael Juma
>            Priority: Major
>             Fix For: 2.2.0
>
>
> A new version of EasyMock and ASM7_EXPERIMENTAL (or ASM7 when Java 11 ships) enabled:
https://github.com/easymock/easymock/issues/224
> EasyMocks shades its dependencies so they can't be upgraded independently.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message