kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guozhang Wang <wangg...@gmail.com>
Subject Re: [DISCUSS] KIP-205: Add getAllKeys() API to ReadOnlyWindowStore
Date Thu, 26 Oct 2017 20:38:18 GMT
Hello Richard, Xavier:

I think I am convinced my your arguments. How about keeping all() as is and
rename "range" to "fetchAll" then?


Guozhang



On Thu, Oct 26, 2017 at 9:21 AM, Xavier Léauté <xavier@confluent.io> wrote:

> I don't feel this worth holding up the vote for, if no one else shares my
> concerns.
> On Wed, Oct 25, 2017 at 15:59 Richard Yu <yohan.richard.yu@gmail.com>
> wrote:
>
> > Xavier: There has been two pluses on the voting thread. Are you fine with
> > the current formation?
> >
> > On Tue, Oct 24, 2017 at 4:26 PM, Richard Yu <yohan.richard.yu@gmail.com>
> > wrote:
> >
> > > I think we can come up with this compromise: range(long timeFrom, long
> > > timeTo) will be changed to getKeys(long timeFrom, long timeTo). Sounds
> > fair?
> > >
> > >
> > > On Tue, Oct 24, 2017 at 10:44 AM, Xavier Léauté <xavier@confluent.io>
> > > wrote:
> > >
> > >> >
> > >> > Generally I think having `all / range` is better in terms of
> > consistency
> > >> > with key-value windows. I.e. queries with key are named as `get /
> > fetch`
> > >> > for kv / window stores, and queries without key are named as `range
> /
> > >> all`.
> > >> >
> > >>
> > >> For kv stores, range takes a range of keys, and with this proposal
> range
> > >> on
> > >> window stores would take a range of time, that does not sound
> consistent
> > >> to
> > >> me at all.
> > >>
> > >> We also already have fetch which take both a range of time and keys.
> > >>
> > >
> > >
> >
>



-- 
-- Guozhang

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message