kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Bentley <t.j.bent...@gmail.com>
Subject Re: [DISCUSS] KIP-183 - Change PreferredReplicaLeaderElectionCommand to use AdminClient
Date Wed, 30 Aug 2017 15:26:31 GMT
Hi Ismael,

I agree that `electPreferredReplicaLeader` is a mouthful and am happy to
change it to `electPreferredLeaders`. I'd rename the correspond request and
response similarly.

Should I rename it in the KIP now, even though I initiated a VOTE thread
yesterday?

Cheers,

Tom

On 30 August 2017 at 16:01, Ismael Juma <ismael@juma.me.uk> wrote:

> Hi Tom,
>
> Thanks for the KIP, it's a useful one. I find the proposed method name
> `electPreferredReplicaLeader` a little hard to read. It seems that a small
> change would make it clearer: `electPreferredReplicaAsLeader`. The next
> point is that this is a batch API, so it should ideally be plural like the
> other AdminClient methods. Maybe `electPreferredReplicasAsLeaders`, but
> that's quite a mouthful. Maybe we should shorten it to
> `electPreferredLeaders`. Thoughts?
>
> Ismael
>
> On Wed, Aug 2, 2017 at 6:34 PM, Tom Bentley <t.j.bentley@gmail.com> wrote:
>
> > In a similar vein to KIP-179 I've created KIP-183 (
> > https://cwiki.apache.org/confluence/display/KAFKA/KIP-183+-+Change+
> > PreferredReplicaLeaderElectionCommand+to+use+AdminClient)
> > which is about deprecating the --zookeeper option to
> > kafka-preferred-replica-election.sh and replacing it with an option
> which
> > would use a new AdminClient-based API.
> >
> > As it stands the KIP is focussed on simply moving the existing
> > functionality behind the AdminClient.
> >
> > I'd be grateful for any feedback people may have on this.
> >
> > Thanks,
> >
> > Tom
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message