kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ismael Juma <ism...@juma.me.uk>
Subject Re: [DISCUSS] KIP-184 Rename LogCleaner and related classes to LogCompactor
Date Wed, 09 Aug 2017 07:59:14 GMT
Hi Pranav,

In the JIRA and the previous mailing list thread, some of us wondered if
the benefit is worth the transition pain. To quote Jason:

"The "log cleaner" naming may not be ideal, but
it is not incorrect and some of the terminology used elsewhere makes more
sense given this name (e.g. cleanable ratio, dirty offset). I personally
see little benefit in the name change, especially if we have to propagate
the change to configuration names (and it makes little sense if we do not
do so). My guess is that most users have already gotten used to the "log
cleaner" naming anyway, so adding new configs would just cause confusion."

Do we have any evidence that users actually get confused by the terminology?


On Sat, Aug 5, 2017 at 5:36 PM, Pranav Maniar <pranav9428@gmail.com> wrote:

> Hi All,
> Following a discussion on JIRA KAFKA-1944
> <https://issues.apache.org/jira/browse/KAFKA-1944> . I have created
> KIP-184
> <https://cwiki.apache.org/confluence/display/KAFKA/KIP-
> 184%3A+Rename+LogCleaner+and+related+classes+to+LogCompactor>
> as
> it will require configuration change.
> As per the process I am starting Discussion on mail thread for KIP-184.
> Renaming of configuration "log.cleaner.enable" is discussed on KAFKA-1944.
> But other log.cleaner configuration also seems to be used by cleaner only.
> So to maintain naming consistency, I have proposed to rename all these
> configuration.
> Please provide your suggestion/views for the same. Thanks !
> Thanks,
> Pranav

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message