kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (KAFKA-3881) Remove the replacing logic from "." to "_" in Fetcher
Date Sat, 03 Jun 2017 07:46:04 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-3881?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ismael Juma reassigned KAFKA-3881:
----------------------------------

    Assignee:     (was: Ismael Juma)

> Remove the replacing logic from "." to "_" in Fetcher
> -----------------------------------------------------
>
>                 Key: KAFKA-3881
>                 URL: https://issues.apache.org/jira/browse/KAFKA-3881
>             Project: Kafka
>          Issue Type: Bug
>          Components: consumer, metrics
>            Reporter: Guozhang Wang
>              Labels: newbie
>
> The logic of replacing "." to "_" in metrics names / tags was originally introduced in
the core package's metrics since Graphite treats "." as hierarchy separators (see KAFKA-1902);
for the client metrics, it is supposed that the GraphiteReported should take care of this
itself rather than letting Kafka metrics to special handle for it. In addition, right now
only consumer Fetcher had replace, but producer Sender does not have it actually.
> So we should consider removing this logic in the consumer Fetcher's metrics package.
NOTE that this is a public API backward incompatible change.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message