kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ewen Cheslack-Postava <e...@confluent.io>
Subject Re: Kafka broker startup issue
Date Tue, 23 May 2017 06:04:49 GMT
Version 2 of UpdateMetadataRequest does not exist in version 0.9.0.1. This
suggests that you have a broker with a newer version of Kafka running
against the same ZK broker. Do you have any other versions running? Or is
it possible this is a shared ZK cluster and you're not using a namespace
within ZK for each cluster?

-Ewen

On Mon, May 22, 2017 at 12:33 AM, dhiraj prajapati <dhirajpraj@gmail.com>
wrote:

> Hi,
> I am getting the below exception while starting kafka broker 0.9.0.1:
>
> kafka.common.KafkaException: Version 2 is invalid for
> UpdateMetadataRequest. Valid versions are 0 or 1.
>     at
> kafka.api.UpdateMetadataRequest$.readFrom(UpdateMetadataRequest.scala:58)
>     at kafka.api.RequestKeys$$anonfun$7.apply(RequestKeys.scala:54)
>     at kafka.api.RequestKeys$$anonfun$7.apply(RequestKeys.scala:54)
>     at kafka.network.RequestChannel$Request.<init>(RequestChannel.
> scala:66)
>     at kafka.network.Processor$$anonfun$run$11.apply(
> SocketServer.scala:426)
>     at kafka.network.Processor$$anonfun$run$11.apply(
> SocketServer.scala:421)
>     at scala.collection.Iterator$class.foreach(Iterator.scala:742)
>     at scala.collection.AbstractIterator.foreach(Iterator.scala:1194)
>     at scala.collection.IterableLike$class.foreach(IterableLike.scala:72)
>     at scala.collection.AbstractIterable.foreach(Iterable.scala:54)
>     at kafka.network.Processor.run(SocketServer.scala:421)
>     at java.lang.Thread.run(Thread.java:745)
>
> What could be the issue?
>
> Regards,
> Dhiraj
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message