kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Armin Braun (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KAFKA-4170) required() method not available in joptsimple.OptionSpec<String>
Date Sun, 02 Apr 2017 14:09:41 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-4170?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Armin Braun resolved KAFKA-4170.
--------------------------------
    Resolution: Fixed

Kafka is using jopt-simple 5.0.3 now which contains the require method just fine :)

> required() method not available in joptsimple.OptionSpec<String>
> ----------------------------------------------------------------
>
>                 Key: KAFKA-4170
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4170
>             Project: Kafka
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.10.0.1
>         Environment: java 1.
>            Reporter: Martin Gainty
>            Priority: Critical
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> kafka.tools.StreamResetter.java:
> private static joptsimple.OptionSpec<String> applicationIdOption;
>  private void parseArguments(final String[] args) throws java.io.IOException {
>         final joptsimple.OptionParser optionParser = new joptsimple.OptionParser();
>         applicationIdOption = (optionParser.accepts("application-id", "The Kafka Streams
application ID (application.id)")
>             .withRequiredArg()
>             .ofType(String.class)
>             .describedAs("id")
>             .required();
> //required() method is not available in joptline 4.9 joptline.OptionSpec.java
> <dependency>
>   			<groupId>net.sf.jopt-simple</groupId>
>   			<artifactId>jopt-simple</artifactId>
>   			<version>4.9</version>
>   		</dependency>



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message