kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aneesh (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Deleted] (KAFKA-4823) Creating Kafka Producer on application running on Java older version
Date Fri, 03 Mar 2017 09:29:45 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-4823?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aneesh updated KAFKA-4823:
--------------------------
    Comment: was deleted

(was: [~ijuma]  Kafka 0.8.2.0 worked for me.I did go through REST proxy , but couldn't get
an idea how to implement that.Can you provide some step by step documentation and implemented
Producer/Consumer on the same.)

> Creating Kafka Producer on application running on Java older version
> --------------------------------------------------------------------
>
>                 Key: KAFKA-4823
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4823
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.10.1.1
>         Environment: Application running on Java 1.6
>            Reporter: Aneesh
>
> I have an application running on Java 1.6 which cannot be upgraded.This application need
to have interfaces to post (producer )messages to Kafka server remote box.Also receive messages
as consumer .The code runs fine from my local env which is on java 1.7.But the same producer
and consumer fails when executed within the application with the error
> Caused by: java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version; class=org/apache/kafka/clients/producer/KafkaProducer,
offset=6
> Is there someway I can still do it ?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message