kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Schlansker <sschlans...@opentable.com>
Subject Re: [DISCUSS] KIP-120: Cleanup Kafka Streams builder API
Date Mon, 13 Mar 2017 19:46:33 GMT

> On Mar 13, 2017, at 12:30 PM, Matthias J. Sax <matthias@confluent.io> wrote:
> 
> Jay,
> 
> thanks for your feedback
> 
>> What if instead we called it KStreamsBuilder?
> 
> That's the current name and I personally think it's not the best one.
> The main reason why I don't like KStreamsBuilder is, that we have the
> concepts of KStreams and KTables, and the builder creates both. However,
> the name puts he focus on KStream and devalues KTable.
> 
> I understand your argument, and I am personally open the remove the
> "Topology" part, and name it "StreamsBuilder". Not sure what others
> think about this.

If you worry about that, you could consider "KafkaStreamsBuilder"
which highlights that it is about Kafka Streams the project as
opposed to KStream the feature.  A little bit wordier, but you probably
only type it a couple times.


Mime
View raw message