kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ewen Cheslack-Postava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-4809) sanity_checks/test_verifiable_producer.py should test 0.10.x and not 0.8
Date Mon, 27 Feb 2017 22:00:46 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-4809?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15886610#comment-15886610
] 

Ewen Cheslack-Postava commented on KAFKA-4809:
----------------------------------------------

The reason we want to make sure it works properly against 0.8.2 builds is because it didn't
exist there but we wanted to do upgrade testing. The upgrade testing didn't get implemented
until 0.9, but to do the input/output validation we needed that class. So the scripts pull
in the tools jar from a newer version and use them against the older version of Kafka. We
took care in doing this such that the only thing being used from the newer version is that
class.

We could certainly test more versions (though as this is just a basic sanity check I'm not
sure we need more than one case for each major version), but since 0.8.2 requires special
handling it's probably the most important of these. (Although I also think most of the things
under sanity_checks should be disabled by default since they get exercised by the "real" tests
anyway.)

> sanity_checks/test_verifiable_producer.py should test 0.10.x and not 0.8
> ------------------------------------------------------------------------
>
>                 Key: KAFKA-4809
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4809
>             Project: Kafka
>          Issue Type: Bug
>            Reporter: Colin P. McCabe
>            Assignee: Colin P. McCabe
>
> {{sanity_checks/test_verifiable_producer.py}} should test the latest 0.10.0, 0.10.1 and
0.10.2 releases.  It should also not test 0.8.2.2, since there appears to be no {{VerifiableProducer}}
class in Kafka 0.8.2.2.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message