kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Gustafson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-4257) Inconsistencies in 0.10.1 upgrade docs
Date Fri, 07 Oct 2016 17:24:21 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-4257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15555692#comment-15555692
] 

Jason Gustafson commented on KAFKA-4257:
----------------------------------------

[~jeff.klukas@gmail.com] Can we resolve this issue with Ismael's improvements merged?

> Inconsistencies in 0.10.1 upgrade docs 
> ---------------------------------------
>
>                 Key: KAFKA-4257
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4257
>             Project: Kafka
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 0.10.1.0
>            Reporter: Jeff Klukas
>            Priority: Minor
>             Fix For: 0.10.1.0
>
>
> There are several inconsistencies in the 0.10.1.0 upgrade docs that make it difficult
to determine what client versions are compatible with what broker versions.
> The initial heading in the upgrade docs is "Upgrading from 0.10.0.X to 0.10.1.0", but
it includes clauses about versions prior to 0.10. Is the intention for these instructions
to be valid for upgrading from brokers as far back as 0.8? Should this section simply be called
"Upgrading to 0.10.1.0"?
> I cannot tell from the docs whether I can upgrade to 0.10.1.0 clients on top of 0.10.0.X
brokers. In particular, step 5 of the upgrade instructions mentions "Once all consumers have
been upgraded to 0.10.0". Should that read 0.10.1, or is the intention here truly that clients
on 9.X or below need to be at version 0.10.0.0 at a minimum?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message