kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Musselman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-2607) Review `Time` interface and its usage
Date Mon, 17 Oct 2016 18:35:59 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-2607?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15583043#comment-15583043
] 

Andrew Musselman commented on KAFKA-2607:
-----------------------------------------

Looks like the PR has conflicts now; is this still in progress or is it still blocked by KAFKA-2247?

> Review `Time` interface and its usage
> -------------------------------------
>
>                 Key: KAFKA-2607
>                 URL: https://issues.apache.org/jira/browse/KAFKA-2607
>             Project: Kafka
>          Issue Type: Improvement
>    Affects Versions: 0.8.2.2
>            Reporter: Ismael Juma
>              Labels: newbie
>
> Two of `Time` interface's methods are `milliseconds` and `nanoseconds` which are implemented
in `SystemTime` as follows:
> {code}
>     @Override
>     public long milliseconds() {
>         return System.currentTimeMillis();
>     }
>     @Override
>     public long nanoseconds() {
>         return System.nanoTime();
>     }
> {code}
> The issue with this interface is that it makes it seem that the difference is about the
unit (`ms` versus `ns`) whereas it's much more than that:
> https://blogs.oracle.com/dholmes/entry/inside_the_hotspot_vm_clocks
> We should probably change the names of the methods and review our usage to see if we're
using the right one in the various places.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message