kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "syam prasad (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-4097) "Server not found in kerberos database" issue while starting a Kafka server in a secured mode
Date Tue, 30 Aug 2016 06:38:21 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-4097?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15448218#comment-15448218
] 

syam prasad commented on KAFKA-4097:
------------------------------------

I was able to identify the root cause for this issue. the SPN for zookeeper was not constructed
in a correct way. This can be seen by enabling kerberos logs (-Dsun.security.krb5.debug=true).
As NSLOOKUP command returns correct hostname in FQDN format, I have never suspected /etc/hosts
file. But there is some problem with /etc/hosts file.

The conventional format of hosts file should be some thing like below:
< IP >	<FQDN>	<ShortName>

Example:
9.124.101.5	archimedes.in.ibm.com	archimedes

But in my hosts file, shortname precedes FQDN. Hence the issue.

Thanks for your time.


> "Server not found in kerberos database" issue while starting a Kafka server in a secured
mode
> ---------------------------------------------------------------------------------------------
>
>                 Key: KAFKA-4097
>                 URL: https://issues.apache.org/jira/browse/KAFKA-4097
>             Project: Kafka
>          Issue Type: Test
>    Affects Versions: 0.10.0.1
>            Reporter: syam prasad
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message