kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gwen Shapira (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-3633) Kafka Consumer API breaking backward compatibility
Date Thu, 28 Apr 2016 19:04:13 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-3633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15262756#comment-15262756
] 

Gwen Shapira commented on KAFKA-3633:
-------------------------------------

It doesn't cause immediate issues, but it makes the API more confusing for new users.

I'm not against (except for the bad timing, I thought the discussion was over a while back),
but since it is a public API change, please raise the issue in the mailing list? (Technically
it requires a KIP, but we can treat it as a continuation of KIP-45 discussion)

> Kafka Consumer API breaking backward compatibility
> --------------------------------------------------
>
>                 Key: KAFKA-3633
>                 URL: https://issues.apache.org/jira/browse/KAFKA-3633
>             Project: Kafka
>          Issue Type: Bug
>            Reporter: Sriharsha Chintalapani
>            Assignee: Sriharsha Chintalapani
>            Priority: Blocker
>             Fix For: 0.10.0.0
>
>
> KAFKA-2991 and KAFKA-3006 broke the backward compatibility. In storm we already using
0.9.0.1 consumer api for the KafkaSpout. We should atleast kept the older methods and shouldn't
be breaking backward compatibility.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message