kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ismael Juma (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KAFKA-2607) Review `Time` interface and its usage
Date Fri, 02 Oct 2015 12:16:26 GMT
Ismael Juma created KAFKA-2607:

             Summary: Review `Time` interface and its usage
                 Key: KAFKA-2607
                 URL: https://issues.apache.org/jira/browse/KAFKA-2607
             Project: Kafka
          Issue Type: Improvement
    Affects Versions:
            Reporter: Ismael Juma

Two of `Time` interface's methods are `milliseconds` and `nanoseconds` which are implemented
in `SystemTime` as follows:

    public long milliseconds() {
        return System.currentTimeMillis();

    public long nanoseconds() {
        return System.nanoTime();

The issue with this interface is that it makes it seem that the difference is about the unit
(`ms` versus `ns`) whereas it's much more than that:


We should probably change the names of the methods and review our usage to see if we're using
the right one in the various places.

This message was sent by Atlassian JIRA

View raw message