kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Stein (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-1163) see whats going on with the 2.8.0 pom
Date Thu, 05 Dec 2013 14:18:37 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-1163?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13840099#comment-13840099
] 

Joe Stein commented on KAFKA-1163:
----------------------------------

./sbt "++VERSION publish" and ./sbt "++VERSION publish-local"

I tried doing ./sbt +publish and that resulted in the so some really "whacky" results up in
maven repository... I then went through and did

./sbt "++2.8.0 publish"
./sbt "++2.8.2 publish"
./sbt "++2.9.1 publish"
./sbt "++2.9.2 publish"
./sbt "++2.10.1 publish" 

I have seen some odd occurrences having to redo these with nexus so it is possible that something
went wrong in the process.  

I think the first thing to confirm is a ./sbt "++2.8.0 publish-local" and ./sbt "++2.8.0 publish"
working ... if it is then it was a matter of process that went wrong and more testing ...
if those don't work (which I suspect the former) digging into the code for what is wrong (I
don't see anything in the code doing it so it would then be in sbt possibly) but again...
I got my money on something going wrong with the upload...

> see whats going on with the 2.8.0 pom
> -------------------------------------
>
>                 Key: KAFKA-1163
>                 URL: https://issues.apache.org/jira/browse/KAFKA-1163
>             Project: Kafka
>          Issue Type: Improvement
>    Affects Versions: 0.8.0
>            Reporter: Joe Stein
>              Labels: release
>             Fix For: 0.8.1
>
>
> assuming we are going to even support 2.8.0 anymore in 0.8.1 =8^/
> "The POM for 2.8.2, 2.9.1, 2.9.2, and 2.10 include scala-compiler and some other stuff
that is not included in 2.8.0
> 2.8.0 https://repository.apache.org/content/groups/staging/org/apache/kafka/kafka_2.8.0/0.8.0/kafka_2.8.0-0.8.0.pom
> 2.8.2 https://repository.apache.org/content/groups/staging/org/apache/kafka/kafka_2.8.2/0.8.0/kafka_2.8.2-0.8.0.pom
> Here's a diff of those two: https://gist.github.com/mumrah/7bd6bd8e2805210d5d9d/revisions
> I think maybe the 2.8.0 POM is missing some stuff it needs (zkclient, snappy, yammer
metrics). "



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message