kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jun Rao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-826) Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x
Date Tue, 02 Apr 2013 22:37:15 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13620363#comment-13620363
] 

Jun Rao commented on KAFKA-826:
-------------------------------

Otis,

The reason that we want to downgrade metrics to 2.x is because quite a few people feel this
is the most stable version that they can depend on. Do you know how stable is this beta release?
Will there be any API or bean name change btw the final 3.x release and this beta release?

In general, do people feel comfortable about using the metrics 3.0 beta release?
                
> Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x
> -----------------------------------------------------
>
>                 Key: KAFKA-826
>                 URL: https://issues.apache.org/jira/browse/KAFKA-826
>             Project: Kafka
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 0.8
>            Reporter: Neha Narkhede
>            Assignee: Jun Rao
>            Priority: Blocker
>              Labels: build, kafka-0.8, metrics
>         Attachments: kafka-fix-for-826.patch, kafka-fix-for-826-take2.patch
>
>
> In order to mavenize Kafka 0.8, we have to depend on metrics 2.2.0 since metrics 3.x
is a huge change as well as not an officially supported release.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message