kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jun Rao <jun...@gmail.com>
Subject Re: compiling and running using intellij
Date Sun, 01 Jan 2012 21:10:34 GMT
1. You may have to rerun sbt idea after update.

2. It's kafka.Kafka.

Jun

On Sat, Dec 31, 2011 at 7:36 PM, S Ahmed <sahmed1020@gmail.com> wrote:

> So I have the scala plugin installed.
>
> ./sbt update and ./sbt test runs fine, all test pass.
>
> 1.  Why am I seeing this in my editor (screenshots):
>
> http://img210.imageshack.us/slideshow/webplayer.php?id=screenshot20111231at103.png
>   Is this normal in IntelliJ?  I guess all compilation has to be done via
> sbt and the editor is just for editing and never for building?
>
>
> 2.  Where exactly is that singleton I should be running via intellij?
>
>
> On Thu, Dec 29, 2011 at 10:57 AM, Jun Rao <junrao@gmail.com> wrote:
>
> > I am using 9.04 and 10.5. The scala plugin seems to mostly work for both.
> >
> > Thanks,
> >
> > Jun
> >
> > On Sun, Dec 25, 2011 at 12:50 PM, S Ahmed <sahmed1020@gmail.com> wrote:
> >
> > > I have IntelliJ 9.0, will the scala plugin work?
> > >
> > > On Sat, Dec 24, 2011 at 5:59 PM, Jun Rao <junrao@gmail.com> wrote:
> > >
> > > > There is a singleton called Kafka and it takes a server.properties
> file
> > > in
> > > > the input.
> > > >
> > > > Jun
> > > >
> > > > On Sat, Dec 24, 2011 at 11:34 AM, S Ahmed <sahmed1020@gmail.com>
> > wrote:
> > > >
> > > > > Thanks :)
> > > > >
> > > > > So can you outline how to start kafka in intelliJ for me?  (I
> really
> > > > > appreciate your time)
> > > > >
> > > > >
> > > > >
> > > > > On Sat, Dec 24, 2011 at 1:22 AM, Jun Rao <junrao@gmail.com>
wrote:
> > > > >
> > > > > > Here is my reply to your previous email:
> > > > > >
> > > > > > For debugging, you can either start Kafka in intellij or attach
> > > > intellij
> > > > > to
> > > > > > a remote jvm running kafka.
> > > > > >
> > > > > > Jun
> > > > > >
> > > > > > On Fri, Dec 23, 2011 at 1:18 PM, S Ahmed <sahmed1020@gmail.com>
> > > wrote:
> > > > > >
> > > > > > > So I ran ./sbt idea and was able to open the project in
IDEA.
> > > > > > >
> > > > > > > Making/building the project in IDEA doesn't work, I guess
it
> > > > shouldn't
> > > > > > > since sbt is used.
> > > > > > >
> > > > > > > ./sbt update and ./sbt builds everything fine, ./sbt
> package-all
> > > also
> > > > > > > worked fine.
> > > > > > >
> > > > > > > How do I go about running kafka in debug mode?
> > > > > > > Do I have to run zookeeper first?
> > > > > > >
> > > > > > > Which project should I run?
> > > > > > >
> > > > > > > Since a native Built | Make project doesn't work, not sure
how
> I
> > > can
> > > > > use
> > > > > > > IDEA in debug mode.
> > > > > > >
> > > > > > > if someone can outline the steps (without assuming too
much!) I
> > > would
> > > > > > > greatly appreciate it!
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message