kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lind...@apache.org
Subject [kafka-site] branch asf-site updated: Update html links for 2.1.0 release (#170)
Date Wed, 21 Nov 2018 17:56:21 GMT
This is an automated email from the ASF dual-hosted git repository.

lindong pushed a commit to branch asf-site
in repository https://gitbox.apache.org/repos/asf/kafka-site.git


The following commit(s) were added to refs/heads/asf-site by this push:
     new 89c0f8e  Update html links for 2.1.0 release (#170)
89c0f8e is described below

commit 89c0f8ee57863c0989c2f3e07e89072799919ff3
Author: Dong Lin <lindong28@gmail.com>
AuthorDate: Wed Nov 21 09:56:17 2018 -0800

    Update html links for 2.1.0 release (#170)
---
 documentation.html |  2 +-
 downloads.html     | 51 ++++++++++++++++++++++++++++++++++++++++++++++-----
 intro.html         |  2 +-
 protocol.html      |  2 +-
 quickstart.html    |  2 +-
 5 files changed, 50 insertions(+), 9 deletions(-)

diff --git a/documentation.html b/documentation.html
index a3f2a83..f71e8a0 100644
--- a/documentation.html
+++ b/documentation.html
@@ -1,2 +1,2 @@
 <!-- should always link the the latest release's documentation -->
-<!--#include virtual="20/documentation.html" -->
+<!--#include virtual="21/documentation.html" -->
diff --git a/downloads.html b/downloads.html
index 1603033..02da20a 100644
--- a/downloads.html
+++ b/downloads.html
@@ -5,12 +5,53 @@
 	<div class="right">
     <h1>Download</h1>
 
-    <p>2.0.1 is the latest release. The current stable version is 2.0.1.</p>
+    <p>2.1.0 is the latest release. The current stable version is 2.1.0.</p>
 
     <p>
     You can verify your download by following these <a href="https://www.apache.org/info/verification.html">procedures</a>
and using these <a href="https://kafka.apache.org/KEYS">KEYS</a>.
     </p>
 
+    <span id="2.1.0"></span>
+    <h3 class="download-version">2.1.0<a href="#2.1.0"><i class="fas fa-link
" style="color:#053ce2"></i></a></h3>
+        <ul>
+            <li>
+                Released Nov 20, 2018
+            </li>
+            <li>
+                <a href="https://www.apache.org/dist/kafka/2.1.0/RELEASE_NOTES.html">Release
Notes</a>
+            </li>
+            <li>
+                Source download: <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.1.0/kafka-2.1.0-src.tgz">kafka-2.1.0-src.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.1.0/kafka-2.1.0-src.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.1.0/kafka-2.1.0-src.tgz.sha512">sha512</a>)
+            </li>
+            <li>
+                Binary downloads:
+                <ul>
+                    <li>Scala 2.11 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.1.0/kafka_2.11-2.1.0.tgz">kafka_2.11-2.1.0.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.1.0/kafka_2.11-2.1.0.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.1.0/kafka_2.11-2.1.0.tgz.sha512">sha512</a>)</li>
+                    <li>Scala 2.12 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.1.0/kafka_2.12-2.1.0.tgz">kafka_2.12-2.1.0.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.1.0/kafka_2.12-2.1.0.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.1.0/kafka_2.12-2.1.0.tgz.sha512">sha512</a>)</li>
+                </ul>
+                We build for multiple versions of Scala. This only matters if you are using
Scala and you want a version built for the same Scala version you use. Otherwise any version
should work (2.12 is recommended).
+            </li>
+        </ul>
+
+        <p>
+            Kafka 2.1.0 includes a number of significant new features. Here is a summary
of some notable changes:
+        </p>
+
+        <ul>
+          <li>Java 11 support</li>
+          <li>Support for Zstandard, which achieves compression comparable to gzip
with higher compression and especially decompression speeds (KIP-110)</li>
+          <li>Avoid expiring committed offsets for active consumer group (KIP-211)</li>
+          <li>Provide Intuitive User Timeouts in The Producer (KIP-91)</li>
+          <li>Kafka's replication protocol now supports improved fencing of zombies.
Previously, under certain rare conditions, if a broker became partitioned
+              from Zookeeper but not the rest of the cluster, then the logs of replicated
partitions could diverge and cause data loss in the worst case (KIP-320).</li>
+          <li>Streams API improvements (KIP-319, KIP-321, KIP-330, KIP-353, KIP-356)</li>
+          <li>Admin script and admin client API improvements to simplify admin operation
(KIP-231, KIP-308, KIP-322, KIP-324, KIP-338, KIP-340)</li>
+          <li>DNS handling improvements (KIP-235, KIP-302)</li>
+        </ul>
+        <p>
+            For more information, please read the detailed <a href="https://www.apache.org/dist/kafka/2.1.0/RELEASE_NOTES.html">Release
Notes</a>.
+        </p>
+
     <span id="2.0.1"></span>
     <h3 class="download-version">2.0.1<a href="#2.0.1"><i class="fas fa-link
" style="color:#053ce2"></i></a></h3>
         <ul>
@@ -29,7 +70,7 @@
                     <li>Scala 2.11 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.1/kafka_2.11-2.0.1.tgz">kafka_2.11-2.0.1.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.0.1/kafka_2.11-2.0.1.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.0.1/kafka_2.11-2.0.1.tgz.sha512">sha512</a>)</li>
                     <li>Scala 2.12 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.1/kafka_2.12-2.0.1.tgz">kafka_2.12-2.0.1.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.0.1/kafka_2.12-2.0.1.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.0.1/kafka_2.12-2.0.1.tgz.sha512">sha512</a>)</li>
                 </ul>
-                We build for multiple versions of Scala. This only matters if you are using
Scala and you want a version built for the same Scala version you use. Otherwise any version
should work (2.11 is recommended).
+                We build for multiple versions of Scala. This only matters if you are using
Scala and you want a version built for the same Scala version you use. Otherwise any version
should work (2.12 is recommended).
             </li>
 
         </ul>
@@ -44,13 +85,13 @@
                 <a href="https://www.apache.org/dist/kafka/2.0.0/RELEASE_NOTES.html">Release
Notes</a>
             </li>
             <li>
-                Source download: <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.0/kafka-2.0.0-src.tgz">kafka-2.0.0-src.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.0.0/kafka-2.0.0-src.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.0.0/kafka-2.0.0-src.tgz.sha512">sha512</a>)
+                Source download: <a href="https://archive.apache.org/dist/kafka/2.0.0/kafka-2.0.0-src.tgz">kafka-2.0.0-src.tgz</a>
(<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka-2.0.0-src.tgz.asc">asc</a>,
<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka-2.0.0-src.tgz.sha512">sha512</a>)
             </li>
             <li>
                 Binary downloads:
                 <ul>
-                    <li>Scala 2.11 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.0/kafka_2.11-2.0.0.tgz">kafka_2.11-2.0.0.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.0.0/kafka_2.11-2.0.0.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.0.0/kafka_2.11-2.0.0.tgz.sha512">sha512</a>)</li>
-                    <li>Scala 2.12 &nbsp;- <a href="https://www.apache.org/dyn/closer.cgi?path=/kafka/2.0.0/kafka_2.12-2.0.0.tgz">kafka_2.12-2.0.0.tgz</a>
(<a href="https://www.apache.org/dist/kafka/2.0.0/kafka_2.12-2.0.0.tgz.asc">asc</a>,
<a href="https://www.apache.org/dist/kafka/2.0.0/kafka_2.12-2.0.0.tgz.sha512">sha512</a>)</li>
+                    <li>Scala 2.11 &nbsp;- <a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.11-2.0.0.tgz">kafka_2.11-2.0.0.tgz</a>
(<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.11-2.0.0.tgz.asc">asc</a>,
<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.11-2.0.0.tgz.sha512">sha512</a>)</li>
+                    <li>Scala 2.12 &nbsp;- <a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.12-2.0.0.tgz">kafka_2.12-2.0.0.tgz</a>
(<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.12-2.0.0.tgz.asc">asc</a>,
<a href="https://archive.apache.org/dist/kafka/2.0.0/kafka_2.12-2.0.0.tgz.sha512">sha512</a>)</li>
                 </ul>
                 We build for multiple versions of Scala. This only matters if you are using
Scala and you want a version built for the same Scala version you use. Otherwise any version
should work (2.11 is recommended).
             </li>
diff --git a/intro.html b/intro.html
index fffd4a8..ba62f60 100644
--- a/intro.html
+++ b/intro.html
@@ -4,7 +4,7 @@
   <!--#include virtual="includes/_nav.htm" -->
   <div class="right">
 		<h1>Introduction</h1>
-    <!--#include virtual="20/introduction.html" -->
+    <!--#include virtual="21/introduction.html" -->
 
 <!--#include virtual="includes/_footer.htm" -->
 
diff --git a/protocol.html b/protocol.html
index 2ee03d5..1d15fcd 100644
--- a/protocol.html
+++ b/protocol.html
@@ -1,2 +1,2 @@
 <!-- should always link the the latest release's documentation -->
-<!--#include virtual="20/protocol.html" -->
+<!--#include virtual="21/protocol.html" -->
diff --git a/quickstart.html b/quickstart.html
index f4be302..4fbf30e 100644
--- a/quickstart.html
+++ b/quickstart.html
@@ -4,7 +4,7 @@
   <!--#include virtual="includes/_nav.htm" -->
   <div class="right">
     <h1>Quickstart</h1>
-    <!--#include virtual="20/quickstart.html" -->
+    <!--#include virtual="21/quickstart.html" -->
 <!--#include virtual="includes/_footer.htm" -->
 <script>
 // Show selected style on nav item


Mime
View raw message