kafka-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From damian...@apache.org
Subject [kafka] branch trunk updated: MINOR: Fix streams broker compatibility test.
Date Tue, 20 Feb 2018 17:47:58 GMT
This is an automated email from the ASF dual-hosted git repository.

damianguy pushed a commit to branch trunk
in repository https://gitbox.apache.org/repos/asf/kafka.git


The following commit(s) were added to refs/heads/trunk by this push:
     new 57059d4  MINOR: Fix streams broker compatibility test.
57059d4 is described below

commit 57059d40223d6284d1b2c9f3034b30f6bd61c44f
Author: Damian Guy <damian.guy@gmail.com>
AuthorDate: Tue Feb 20 17:46:05 2018 +0000

    MINOR: Fix streams broker compatibility test.
    
    Change the string in the test condition to the one that is logged
    
    Author: Damian Guy <damian.guy@gmail.com>
    
    Reviewers: Bill Bejeck <bill@confluent.io>, Guozhang Wang <wangguoz@gmail.com>
    
    Closes #4599 from dguy/broker-compatibility
---
 tests/kafkatest/tests/streams/streams_broker_compatibility_test.py | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
index 1eb46ef..b00b9bb 100644
--- a/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
+++ b/tests/kafkatest/tests/streams/streams_broker_compatibility_test.py
@@ -67,9 +67,9 @@ class StreamsBrokerCompatibility(Test):
 
         processor.node.account.ssh(processor.start_cmd(processor.node))
         with processor.node.account.monitor_log(processor.STDERR_FILE) as monitor:
-            monitor.wait_until('FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support LIST_OFFSETS ',
+            monitor.wait_until("Exception in thread \"main\" org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support LIST_OFFSETS ",
                                timeout_sec=60,
-                               err_msg="Never saw 'FATAL: An unexpected exception org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support LIST_OFFSETS ' error message " + str(processor.node.account))
+                               err_msg="Exception in thread \"main\" org.apache.kafka.common.errors.UnsupportedVersionException:
The broker does not support LIST_OFFSETS " + str(processor.node.account))
 
         self.kafka.stop()
 

-- 
To stop receiving notification emails like this one, please contact
damianguy@apache.org.

Mime
View raw message