juddi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pasquale Campitiello" <pas.campitie...@gmail.com>
Subject Re: Fwd: Link jUDDI 0.9rc4 to Synapse 1.2
Date Wed, 03 Dec 2008 22:37:38 GMT
Ok. We solved that problem.

I reinstalled the *JDK 5.0 Update 10*. The problem was not in the CLASSPATH
or the JAVA_HOME, but it was the JVM used by Apache Tomcat: I right clicked
on the Monitor Tomcat icon --> Configure... --> tab Java --> browse and set
the JDK 5.0_10 JVM (in my case
C:\Programmi\Java\jdk_jee_5u10\jdk\jre\bin\server\jvm.dll).

Thank you, I go on with the project to link jUDDI 0.9rc4 to Synapse 1.2.

Pasquale




2008/12/3 Jeff Faath <jfaath@apache.org>

>  Have you tried setting logging to 'debug' for juddi and inspecting the
> log file.  You should be able to get much more detailed information about
> what is going on.
>
>
>
> *From:* Pasquale Campitiello [mailto:pas.campitiello@gmail.com]
> *Sent:* Tuesday, December 02, 2008 5:26 PM
> *To:* juddi-dev@ws.apache.org
> *Subject:* Re: Fwd: Link jUDDI 0.9rc4 to Synapse 1.2
>
>
>
> I continued googling but I really don't undestand this error. I tried to
> insert other publishers, but it's the same.
> When I click in *get_authToken* in *userID *I have to insert the publisher
> ID and in *cred *the password? But, what password? Or I have to insert
> something else (credentials)? I tried everything... but I really don't know.
>
> <?xml version="1.0" encoding="utf-8"?>
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
> ">
>   <soapenv:Body>
>     <get_authToken generic="2.0" xmlns="urn:uddi-org:api_v2"
>       userID="***"
>       cred="***"/>
>   </soapenv:Body>
> </soapenv:Envelope>
>
> My system details are:
>
> Windows XP SP2
> Apache TomCat 5.5
> jUDDI Version: 0.9rc4   [ I have to use versione 0.9 not 2.0. Is it
> possible to update 0.9 to the recent one? ]
>   Build Date: 14 giugno 2005 7.20.20 CEST
>   UDDI Version: 2.0
> MySQL Server 5.1
> Java version "1.6.0_10"
>
>
>
> Thanks
>
> Pasquale Campitiello
>
>
>  2008/12/1 Pasquale Campitiello <pas.campitiello@gmail.com>
>
> In the console, when I click on get_authToken I get the form with:
>
>
>
> <?xml version="1.0" encoding="utf-8"?>
>
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
> ">
>   <soapenv:Body>
>     <get_authToken generic="2.0" xmlns="urn:uddi-org:api_v2"
>       userID="***"
>       cred="***"/>
>   </soapenv:Body>
> </soapenv:Envelope>
>
> In the "***" of userID and cred I tried the combinations "juddi" + "juddi"
> or   "juddi" + ""  or   "juddi" + "123456"  or  "jdoe" + "" but it's the
> same error.
>
>  2008/12/1 Pasquale Campitiello <pas.campitiello@gmail.com>
>
>
>
> Yes. To configure jUDDI I followed the official document
>
>
>
> http://svn.apache.org/viewvc/webservices/juddi/trunk/docs/Getting-Started.pdf?revision=547750
>
> so my configuration file are exactly like specified in the document, and
> when I click Validate in http://localhost:8080/juddi/ my "jUDDI DataSource
> Validation" section is:
>
>  jUDDI DataSource Validation
>
>  + Got a JNDI Context!
>  + Got a JDBC DataSource (dsname=java:comp/env/jdbc/juddiDB)
>  + Got a JDBC Connection!
>  + SELECT COUNT(*) FROM PUBLISHER = 1
>
>
> In fact if I verify with MySQL:
>
>
>  mysql> use juddi;
>  Database changed
>  mysql> select * from publisher;
>  +--------------+----------------+---------------+----------+------------+
>  | PUBLISHER_ID | PUBLISHER_NAME | EMAIL_ADDRESS | IS_ADMIN | IS_ENABLED |
>  +--------------+----------------+---------------+----------+------------+
>  | juddi        | juddi          | 123@123.org   | true     | true       |
>  +--------------+----------------+---------------+----------+------------+
>  1 row in set (0.00 sec)
>
>
>
>  2008/12/1 Kurt T Stam <kurt.stam@gmail.com>
>
>
>
> Hi Pasquale,
>
> Did you add a publisher?
>
>
> http://svn.apache.org/viewvc/webservices/juddi/trunk/src/main/resources/juddi-sql/insert_publishers.sql?view=markup
>
> --K
>
>
>
> Pasquale Campitiello wrote:
>
> Hi,
>
>
> I'm an italian student. I'm trying to link Apache Synapse and jUDDI 0.9rc4.
> In order to implement the interface to link them I have to know how jUDDI
> "looks" to WSDL, how jUDDI can provide UDDI methods etc..
> I configured correctly jUDDI: I can see the "Happy jUDDI!" page without
> errors.
> But I have a common problem: in the jUDDI console when I click
> get_authToken to obtain an authentication token, and I insert my user and
> cred I get always the same error:
>
> <?xml version="1.0" encoding="utf-8" ?>
> <SOAP-ENV:Envelope xmlns:SOAP-ENV="
> http://schemas.xmlsoap.org/soap/envelope/">
>
> <SOAP-ENV:Header/>
>
> <SOAP-ENV:Body>
>
> <SOAP-ENV:Fault>
>
> <faultcode>SOAP-ENV:Server</faultcode>
>
> <faultstring>Fault string, and possibly fault code, not set</faultstring>
>
> </SOAP-ENV:Fault>
>
> </SOAP-ENV:Body>
>
> </SOAP-ENV:Envelope>
>
> I tried every possible combination of user and cred ("juddi" + "juddi",
> "juddi" + "";    "juddi" + "123456";    "jdoe" + "",    ecc.), but everytime
> I got this SOAP response. To configure jUDDI I followed the official
> document
>
> http://svn.apache.org/viewvc/webservices/juddi/trunk/docs/Getting-Started.pdf?revision=547750
> so my configuration file are exactly like specified in the document.
>
> Googling I read about changing the JDK version. I tried JDK 5 update 10,
> JDK 5 update 16, JDK + JEE 5 update 10, but nothing changed, and besides
> with this versions I can't run Synapse. Now with JDK + JEE 6 update 10, I
> can run Synapse but I'm still blocked with jUDDI.Someone can help me?
>
> Thanks
>
> Pasquale
>
>
>
>
>
>
>
>
>
>
>

Mime
View raw message