jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerry Malcolm <techst...@malcolms.com>
Subject Login issues after upgrade
Date Mon, 24 Jun 2019 04:58:15 GMT
I just upgraded several of my sites to JSPWiki v2.11.0-M4.  I'm not sure 
what the previous version was.  But it was probably 3 or 4 years old.  I 
am using container-managed authorization.  The same security realm on 
the vHost in Tomcat (v9.0) is shared across several webapps using 
SingleSignOn.  Everything was working prior to the JSPWiki migration.  
After migration, I can't log in directly using the JSPWiki login form to 
the wiki's on any of the sites.  It just keeps coming back with the same 
login form. However, if I log in to another webapp on the same virtual 
host, login works fine, and then I can get to the wiki.

I migrated the security stuff in web-xml from the old version to the new 
version and diff'd the files to make sure I didn't miss anything.   I 
did a SQL trace when I logged in using the JSPWiki login form, and it 
appears that the query for the user record is not even being sent to mysql.

I've coded container-managed authorization many times.  I'm not aware of 
a situation where it would reject the login from this webapp's login 
form, but still accept a pre-existing login (using SingleSignOn) from 
another webapp on the same host.

This problem is consistent across all the vHosts I migrated the new Wiki 
version.  Am I missing something obvious?

Thx

Jerry


Mime
View raw message