jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Louis.Mast...@log-net.com
Subject Re: thumbnails and presentations
Date Tue, 17 Feb 2009 13:52:32 GMT
Bob:

OK, it does seem to work, but only in the page preview.  When I actually 
save the page, it is not a presentation.  My code is below - am I missing 
something?


[{brushed.jspwiki.s5plugin.S5 header='%%(text-align:right;)DRAFT%%' 
       footer='LCM • 2009-01-01 \\\\ TESTING'
       autostart='yes'
  }]

%%slide
%%title-slide
!!! Main Title
!! Sub Title
! Louis Masters
Test slideshow
%%
%%

%%slide
!!! First Slide
* bullet one
* bullet two
%%
%%slide
!!! Second Slide
* bullet one
* bullet two
%%




Thanks,
Lou


Bob Paige <bobpaige@gmail.com> wrote on 02/13/2009 09:58:36 AM:

> I'm running 2.6.3.
> 
> To make it work I do the following:
> 
> 1. copy the s5.jar file to JSPWiki's lib directory
> 2. copy the s5.js, s5.css, an dprototype.js files that come with the 
plugin
> to the scripts directory
> 3. add "brushed.jspwiki.s5plugin" to the jspwiki.plugin.searchPath 
property
> 
> though I see I fully-qualified the plugin. I just confirmed it works 
without
> fully-qualifying it (since it is in the plugin searchpath).
> 
> -- 
> Bobman
> 
> On Fri, Feb 13, 2009 at 9:54 AM, <Louis.Masters@log-net.com> wrote:
> 
> > Bob:
> >
> > How did you get this plugin to work?  What version of the wiki are you
> > running?  I thought this plugin only worked with version 2.3?
> >
> > -Lou
> >
> > Bob Paige <bobpaige@gmail.com> wrote on 02/13/2009 09:24:27 AM:
> >
> > > I have the S5 presentation plugin and am trying to incorporate 
thumbnail
> > > images with it.
> > >
> > > My goal with the thumbnails was to display a small version of the 
image
> > that
> > > the user could click on to see the full size image in a separate 
window.
> > I
> > > accomplished this with the following:
> > >
> > > [{Image src='img.jpg' width='200' link='attach/{$pagename}/img.jpg'
> > > target='_blank'}]
> > >
> > > where 'img.jpg' is the name of the image attached to the current 
page.
> > Note
> > > the "attach/{$pagename}" part in the link argument; JSPWiki puts in 
the
> > > current page name so the link works.
> > >
> > > So this works great. But when I put it in an S5 presentation page,
> > clicking
> > > on the link has no effect. The pointer changes as you would expect 
when
> > you
> > > mouse over a link, but clicking does nothing. When I'm looking at 
the
> > list
> > > view of the presentation the links work fine; they just don't work 
when
> > > displaying the presentation.
> > >
> > > Sample presentation:
> > >
> > > [{brushed.jspwiki.s5plugin.S5 autostart='yes' header='...' 
footer='...'
> > > style='...' }]
> > > %%slide
> > > !!! <title>
> > > * some slide bullet
> > > * another slide bullet
> > > [{Image src='img.jpg' width='200' link='attach/{$pagename}/img.jpg'
> > > target='_blank'}]
> > > ...
> > > %%
> > >
> > >
> > > Any idea why links don't work within a presentation?
> > >
> > > --
> > > Bobman
> >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message