jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janne Jalkanen <Janne.Jalka...@ecyrd.com>
Subject Re: Unit test fails: PageRenamerTest.testBug85_case1
Date Thu, 04 Sep 2008 21:01:43 GMT

It is possible that some test is not clearing up the workspace  
properly.  I remember having similar problems with some  
ReferringPluginTests as while back.

/Janne

On 4 Sep 2008, at 23:13, Harry Metske wrote:

> If I run all the tests (ant tests) from either the shell or in the  
> Eclipse
> workspace, I always get the two failures in PageRenamerTest.
> If I run a single JUnit test for it, it fails the first time (with  
> the same
> 2 failures), every next JUnit test succeeds.
> I get the two failures again (once) after I run "ant tests" again.
>
> weird......I would think that one of the other tests leaves  
> something behind
> that causes the tests to fail, or the PageRenamerTest leaves something
> behind that makes the second single test succeed while it shouldn't.
>
> It's challenging.....
>
>
> 2008/9/4 Dirk Frederickx <dirk.frederickx@gmail.com>
>
>> Hi guys,
>>
>> Sometime back, I noticed that running those 2 test from a jUnit
>> console - standalone - appeared to run successfully.
>> Did anyone experience the same ?
>>
>> dirk
>>
>>
>> On Thu, Sep 4, 2008 at 8:26 PM, Harry Metske <harry.metske@gmail.com>
>> wrote:
>>> I always run the tests before committing fixes, but know which  
>>> failures
>> can
>>> "safely" be ignored, I guess other members do the same.
>>> It just takes time to fix the bugs that are pointed to by the tests.
>>>
>>> Harry
>>>
>>> 2008/9/4 Florian Holeczek <florian@holeczek.de>
>>>
>>>>> The test is correct and there is a bug.
>>>>
>>>> I always thought the team is running the tests before a release...?
>>>>
>>>> What I want to say: Did Simon really find two bugs by simply  
>>>> running
>>>> the tests, or (what I think) are these test only failing because of
>>>> his "Tomcat and UTF8" problem described in the thread "non-ascii
>>>> characters in file names"?
>>>>
>>>> Simon, is it possible that you run the tests once again in your now
>>>> sane environment and report whether they're still failing?
>>>>
>>>> Regards
>>>>  Florian
>>>>
>>>>
>>>
>>>
>>> --
>>> met vriendelijke groet,
>>> Harry Metske
>>> Telnr. +31-548-512395
>>> Mobile +31-6-51898081
>>>
>>
>
>
>
> -- 
> met vriendelijke groet,
> Harry Metske
> Telnr. +31-548-512395
> Mobile +31-6-51898081


Mime
View raw message