jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <DKra...@mortgagebankers.org>
Subject RE: Pages Not Saving
Date Fri, 29 Aug 2008 13:44:12 GMT
I attempted again this morning in the Sandbox, both with IE7 and FF2, and was not able to replicate.
 The page is saving fine (http://sandbox.jspwiki.org/Wiki.jsp?page=Testje).

It does appear to depend on content.  There are certain pages that seem to never have a problem
and certain pages (like the on I included in the original message) that consistently will
not save.  At a couple points over the last two months I would think that I figured out a
pattern however every time it would eventually get debunked.  The problem is the lack of consistency
in the behavior (as has been demonstrated over the last 24 hours in all of our testing attempts
in the Sandbox and local installs).  Admitedly I don't know much about the underlying architecture
of JSP Wiki but I find it peculiar that this lack of consistency can be found throughout the
various installs people have been testing this problem on.

I have not run a debug trace on JSP Wiki yet.  I will ask my system admin to do so this morning
and report back my findings.

Thank you for all of your help and time.

Dave

________________________________________
From: Harry Metske [harry.metske@gmail.com]
Sent: Friday, August 29, 2008 3:09 AM
To: jspwiki-user@incubator.apache.org
Subject: Re: Pages Not Saving

Dave, me neither, also not on my local JSPWiki installations.
I think we would really need some more specifics, is it depending on the
content of the page, do you see certain patterns there ?
Have you ran a debug trace on jspwiki and what did you notice ?
And, as Janne noted, if the submitted page content doesn't reach the server
at all, it could as well be a problem outside jspwiki.

regards,
Harry

2008/8/29 Janne Jalkanen <Janne.Jalkanen@ecyrd.com>

>
> Now I can't replicate it anymore, even on the sandbox :-(
>
> /Janne
>
>
> On Aug 28, 2008, at 23:06 , <DKrause@mortgagebankers.org> wrote:
>
>  In IE7, while authenticated, problem occurred both on saving and preview.
>>
>> Got it to replicate if FF2 on Sandbox and locally (again after
>> authenticating).
>>
>> -----Original Message-----
>> From: Harry Metske [mailto:harry.metske@gmail.com]
>> Sent: Thursday, August 28, 2008 3:57 PM
>> To: jspwiki-user@incubator.apache.org
>> Subject: Re: Pages Not Saving
>>
>> I could try it with seamonkey, but akismet prevents me from doing any
>> further edits on the sandbox.
>> only authenticated edits are allowed .....
>>
>> Harry
>>
>> 2008/8/28 Janne Jalkanen <Janne.Jalkanen@ecyrd.com>
>>
>>
>>> On 28 Aug 2008, at 22:46, Harry Metske wrote:
>>>
>>>  are you logged in or are you asserted, anyway, I would need the log,
>>>
>>>> I did some experiments and found the following :
>>>>
>>>> - problem only occurs if you are anonymous or asserted, not if you are
>>>> autheticated
>>>>
>>>>
>>> And it does not work with FF3 if you turn on Firebug to monitor your
>>> network traffic...  AGH!
>>>
>>> As far as I can tell; the page edit never even makes it to the server
>>> when
>>> it fails.  It's rejected because there is no difference between the old
>>> page
>>> and new page.
>>>
>>> Can anybody else confirm that Firefox is the only browser that this
>>> occurs
>>> with?
>>>
>>> /Janne
>>>
>>>
>>
>>
>> --
>> met vriendelijke groet,
>> Harry Metske
>> Telnr. +31-548-512395
>> Mobile +31-6-51898081
>>
>
>


--
met vriendelijke groet,
Harry Metske
Telnr. +31-548-512395
Mobile +31-6-51898081

Mime
View raw message