jspwiki-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ALBERTO MARTINEZ" <alberto.marti...@infinitysystem.es>
Subject RE: Problem starting JSPWiki over Windows XP
Date Tue, 08 Apr 2008 16:20:19 GMT
WORKING!!
Thank you very much!!

Let me explain the steps I have followed:

-I've tried to repair the hard disk: Windows sais that it's OK.
-I have dowloaded a zip file with the Tomcat "Plugin" from Apache friends (http://www.apachefriends.org/download.php?xampp-win32-tomcat-addon-6.0.14-2.2.8.zip).
After it, I have copied the "tomcat-users.xml" file overwriting the previous one (I did not
backup it as it was already broken).
-I have restarted Apache Tomcat service, and it works!!!!

The Tomcat version is 6.0.14.
It's installed over Windows XP SP2.

If you need from me any other information that can detail more the problem to help other users
in the future, please, tell me.

Now that it works, I'm going to try to change the Tomcat listening port.


Many many thanks to all!!!! You are great!!
Alberto




-----Mensaje original-----
De: Florian Holeczek [mailto:florian@holeczek.de] 
Enviado el: martes, 08 de abril de 2008 17:34
Para: ALBERTO MARTINEZ
Asunto: Re: Problem starting JSPWiki over Windows XP

Hi Alberto,

> I have checked tomcat-users.xml. It must be "plain text", right? In my 
> server, this file is a binary file full of zeroes. Can this be the 
> problem?

definitely!

Here's an example:
---snip---
<?xml version='1.0' encoding='utf-8'?>
<tomcat-users>
  <role rolename="manager"/>
  <user username="" password="" roles="manager"/>
  <user username="tomcat" password="tomcat" roles="manager"/> </tomcat-users>
---snap---

Save the text between snip and snap as a UTF-8 formatted text file (or simply replace the
file with the original one from the tomcat plugin archive).

Regards,
 Florian

Mime
View raw message