jspwiki-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From juanpa...@apache.org
Subject svn commit: r1470352 - in /incubator/jspwiki/branches/MVN3_BRANCH: jspwiki-it-tests/jspwiki-it-vanilla/pom.xml jspwiki-war/pom.xml mvn_cheat-sheet.txt pom.xml
Date Sun, 21 Apr 2013 21:42:59 GMT
Author: juanpablo
Date: Sun Apr 21 21:42:58 2013
New Revision: 1470352

URL: http://svn.apache.org/r1470352
Log:
JSPWIKI-771: added <dependencyManagement/> section to parent pom

Modified:
    incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-it-tests/jspwiki-it-vanilla/pom.xml
    incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-war/pom.xml
    incubator/jspwiki/branches/MVN3_BRANCH/mvn_cheat-sheet.txt
    incubator/jspwiki/branches/MVN3_BRANCH/pom.xml

Modified: incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-it-tests/jspwiki-it-vanilla/pom.xml
URL: http://svn.apache.org/viewvc/incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-it-tests/jspwiki-it-vanilla/pom.xml?rev=1470352&r1=1470351&r2=1470352&view=diff
==============================================================================
--- incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-it-tests/jspwiki-it-vanilla/pom.xml (original)
+++ incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-it-tests/jspwiki-it-vanilla/pom.xml Sun
Apr 21 21:42:58 2013
@@ -95,13 +95,11 @@
     <dependency>
       <groupId>org.seleniumhq.selenium.client-drivers</groupId>
       <artifactId>selenium-java-client-driver</artifactId>
-      <version>1.0.2</version>
     </dependency>
  
     <dependency>
       <groupId>org.seleniumhq.selenium</groupId>
       <artifactId>selenium-java</artifactId>
-      <version>2.32.0</version>
     </dependency>
  
     <dependency>
@@ -110,7 +108,6 @@
       <!-- <artifactId>selenium-chrome-driver</artifactId> -->
       <!-- <artifactId>selenium-ie-driver</artifactId> -->
       <artifactId>selenium-firefox-driver</artifactId>
-      <version>2.32.0</version>
     </dependency>
   </dependencies>
 </project>
\ No newline at end of file

Modified: incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-war/pom.xml
URL: http://svn.apache.org/viewvc/incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-war/pom.xml?rev=1470352&r1=1470351&r2=1470352&view=diff
==============================================================================
--- incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-war/pom.xml (original)
+++ incubator/jspwiki/branches/MVN3_BRANCH/jspwiki-war/pom.xml Sun Apr 21 21:42:58 2013
@@ -38,164 +38,119 @@
         <dependency>
             <groupId>xmlrpc</groupId>
             <artifactId>xmlrpc</artifactId>
-            <version>2.0.1</version>
         </dependency>
         <dependency>
             <groupId>org.apache.lucene</groupId>
             <artifactId>lucene-highlighter</artifactId>
-            <version>3.6.0</version>
         </dependency>
         <dependency>
             <groupId>javax.servlet</groupId>
             <artifactId>servlet-api</artifactId>
-            <version>2.4</version>
-            <scope>provided</scope>
         </dependency>
         <dependency>
             <groupId>net.sourceforge</groupId>
             <artifactId>sandler</artifactId>
-            <version>0.5</version>
         </dependency>
         <dependency>
             <groupId>opensymphony</groupId>
             <artifactId>oscache</artifactId>
-            <version>2.3</version>
         </dependency>
         <dependency>
             <groupId>oro</groupId>
             <artifactId>oro</artifactId>
-            <version>2.0.7</version>
         </dependency>
         <dependency>
             <groupId>javax.mail</groupId>
             <artifactId>mail</artifactId>
-            <version>1.4</version>
         </dependency>
         <dependency>
             <groupId>log4j</groupId>
             <artifactId>log4j</artifactId>
-            <version>1.2.14</version>
         </dependency>
         <dependency>
             <groupId>javax.servlet.jsp</groupId>
             <artifactId>jsp-api</artifactId>
-            <version>2.0</version>
-            <scope>provided</scope>
         </dependency>
         <dependency>
             <groupId>com.metaparadigm</groupId>
             <artifactId>json-rpc</artifactId>
-            <version>1.0</version>
         </dependency>
         <dependency>
             <groupId>org.jvnet.hudson</groupId>
             <artifactId>org.suigeneris.jrcs.diff</artifactId>
-            <version>0.4.2</version>
         </dependency>
         <dependency>
             <groupId>jdom</groupId>
             <artifactId>jdom</artifactId>
-            <version>1.0</version>
         </dependency>
         <dependency>
             <groupId>javax.servlet</groupId>
             <artifactId>jstl</artifactId>
-            <version>1.1.2</version>
         </dependency>
         <dependency>
             <groupId>org.freshcookies</groupId>
             <artifactId>freshcookies-security</artifactId>
-            <version>0.60</version>
         </dependency>
         <dependency>
             <groupId>ecs</groupId>
             <artifactId>ecs</artifactId>
-            <version>1.4.2</version>
         </dependency>
         <dependency>
             <groupId>commons-lang</groupId>
             <artifactId>commons-lang</artifactId>
-            <version>2.6</version>
         </dependency>
         <dependency>
             <groupId>commons-fileupload</groupId>
             <artifactId>commons-fileupload</artifactId>
-            <version>1.2.1</version>
         </dependency>
         <dependency>
             <groupId>net.sourceforge</groupId>
             <artifactId>akismet-java</artifactId>
-            <version>1.02</version>
         </dependency>
         <dependency>
             <groupId>commons-httpclient</groupId>
             <artifactId>commons-httpclient</artifactId>
-            <version>3.1</version>
         </dependency>
         <dependency>
             <groupId>commons-io</groupId>
             <artifactId>commons-io</artifactId>
-            <version>1.4</version>
-            <scope>runtime</scope>
         </dependency>
         <dependency>
             <groupId>nekohtml</groupId>
             <artifactId>nekohtml</artifactId>
-            <version>0.9.4</version>
-            <scope>runtime</scope>
         </dependency>
         <dependency>
             <groupId>taglibs</groupId>
             <artifactId>standard</artifactId>
-            <version>1.1.2</version>
-            <scope>runtime</scope>
         </dependency>
         <dependency>
             <groupId>jaxen</groupId>
             <artifactId>jaxen</artifactId>
-            <version>1.1-beta-6</version>
-            <exclusions>
-               <exclusion>
-                 <groupId>*</groupId>
-                 <artifactId>*</artifactId>
-               </exclusion>
-            </exclusions>
         </dependency>
         <dependency>
             <groupId>net.sourceforge.stripes</groupId>
             <artifactId>stripes</artifactId>
-            <version>1.5.7</version>
-            <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>org.hsqldb</groupId>
             <artifactId>hsqldb</artifactId>
-            <version>1.8.0.10</version>
-            <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>tomcat</groupId>
             <artifactId>jasper-runtime</artifactId>
-            <version>5.5.23</version>
-            <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>org.eclipse.jetty.aggregate</groupId>
             <artifactId>jetty-all</artifactId>
-            <version>7.6.7.v20120910</version>
-            <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>junit</groupId>
             <artifactId>junit</artifactId>
-            <version>3.8.2</version>
-            <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>org.seleniumhq.selenium</groupId>
             <artifactId>selenium-java</artifactId>
-            <version>2.25.0</version>
-            <scope>test</scope>
+            <scope>test</scope><!-- overwritting sxope defined in parent dpdncyMgmt;
really needed here? -->
         </dependency>
     </dependencies>
 

Modified: incubator/jspwiki/branches/MVN3_BRANCH/mvn_cheat-sheet.txt
URL: http://svn.apache.org/viewvc/incubator/jspwiki/branches/MVN3_BRANCH/mvn_cheat-sheet.txt?rev=1470352&r1=1470351&r2=1470352&view=diff
==============================================================================
--- incubator/jspwiki/branches/MVN3_BRANCH/mvn_cheat-sheet.txt (original)
+++ incubator/jspwiki/branches/MVN3_BRANCH/mvn_cheat-sheet.txt Sun Apr 21 21:42:58 2013
@@ -9,7 +9,7 @@ mvn clean install                    : p
 mvn clean install -Dmaven.skip.test  : performs a build, skipping the tests (not recommended)
 mvn clean test                       : compiles the source and executes the tests
 mvn tomcat7:run                      : (from a war module) starts JSPWiki on a 
-                                       Tomcat7 instance on http://localhost:8080/JSPWiki
+                                       Tomcat7 instance at http://localhost:8080/JSPWiki
                                        
 Selenium execution: go to jspwiki-it-tests module and execute mvn clean test
 

Modified: incubator/jspwiki/branches/MVN3_BRANCH/pom.xml
URL: http://svn.apache.org/viewvc/incubator/jspwiki/branches/MVN3_BRANCH/pom.xml?rev=1470352&r1=1470351&r2=1470352&view=diff
==============================================================================
--- incubator/jspwiki/branches/MVN3_BRANCH/pom.xml (original)
+++ incubator/jspwiki/branches/MVN3_BRANCH/pom.xml Sun Apr 21 21:42:58 2013
@@ -48,6 +48,229 @@
     <!-- <module>jspwiki-it-tests</module> --><!-- don't launch the
IT tests as part of the main build -->
   </modules>
   
+  <dependencyManagement> <!-- defines what configuration is going to be used if,
and only if, the dependency is used -->
+    <dependencies>       <!-- ordered alphabetically by scope:groupId:artifactId
                                    -->
+      <!-- compile dependencies -->
+      <dependency>
+        <groupId>com.metaparadigm</groupId>
+        <artifactId>json-rpc</artifactId>
+        <version>1.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>commons-fileupload</groupId>
+        <artifactId>commons-fileupload</artifactId>
+        <version>1.2.1</version>
+      </dependency>
+
+      <dependency>
+        <groupId>commons-httpclient</groupId>
+        <artifactId>commons-httpclient</artifactId>
+        <version>3.1</version>
+      </dependency>
+
+      <dependency>
+        <groupId>commons-lang</groupId>
+        <artifactId>commons-lang</artifactId>
+        <version>2.6</version>
+      </dependency>
+
+      <dependency>
+        <groupId>ecs</groupId>
+        <artifactId>ecs</artifactId>
+        <version>1.4.2</version>
+      </dependency>
+
+      <dependency>
+        <groupId>javax.mail</groupId>
+        <artifactId>mail</artifactId>
+        <version>1.4</version>
+      </dependency>
+
+      <dependency>
+        <groupId>javax.servlet</groupId>
+        <artifactId>jstl</artifactId>
+        <version>1.1.2</version>
+      </dependency>
+
+      <dependency>
+        <groupId>jaxen</groupId>
+        <artifactId>jaxen</artifactId>
+        <version>1.1-beta-6</version>
+        <exclusions>
+          <exclusion>
+            <groupId>*</groupId>
+            <artifactId>*</artifactId>
+          </exclusion>
+        </exclusions>
+      </dependency>
+
+      <dependency>
+        <groupId>jdom</groupId>
+        <artifactId>jdom</artifactId>
+        <version>1.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>log4j</groupId>
+        <artifactId>log4j</artifactId>
+        <version>1.2.14</version>
+      </dependency>
+
+      <dependency>
+        <groupId>net.sourceforge</groupId>
+        <artifactId>akismet-java</artifactId>
+        <version>1.02</version>
+      </dependency>
+
+      <dependency>
+        <groupId>net.sourceforge</groupId>
+        <artifactId>sandler</artifactId>
+        <version>0.5</version>
+      </dependency>
+
+      <dependency>
+        <groupId>opensymphony</groupId>
+        <artifactId>oscache</artifactId>
+        <version>2.3</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.apache.lucene</groupId>
+        <artifactId>lucene-highlighter</artifactId>
+        <version>3.6.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.freshcookies</groupId>
+        <artifactId>freshcookies-security</artifactId>
+        <version>0.60</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.jvnet.hudson</groupId>
+        <artifactId>org.suigeneris.jrcs.diff</artifactId>
+        <version>0.4.2</version>
+      </dependency>
+ 
+      <dependency>
+        <groupId>org.seleniumhq.selenium</groupId>
+        <artifactId>selenium-chrome-driver</artifactId>
+        <artifactId>selenium-firefox-driver</artifactId>
+        <version>2.32.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.seleniumhq.selenium</groupId>
+        <artifactId>selenium-firefox-driver</artifactId>
+        <version>2.32.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.seleniumhq.selenium</groupId>
+        <artifactId>selenium-ie-driver</artifactId>
+        <version>2.32.0</version>
+      </dependency>
+
+      <dependency>
+        <groupId>org.seleniumhq.selenium</groupId>
+        <artifactId>selenium-java</artifactId>
+        <version>2.32.0</version>
+      </dependency>
+                
+      <dependency>
+        <groupId>org.seleniumhq.selenium.client-drivers</groupId>
+        <artifactId>selenium-java-client-driver</artifactId>
+        <version>1.0.2</version>
+      </dependency>
+
+      <dependency>
+        <groupId>oro</groupId>
+        <artifactId>oro</artifactId>
+        <version>2.0.7</version>
+      </dependency>
+
+      <dependency>
+        <groupId>xmlrpc</groupId>
+        <artifactId>xmlrpc</artifactId>
+        <version>2.0.1</version>
+      </dependency>
+
+      <!-- test dependencies -->
+      <dependency>
+        <groupId>junit</groupId>
+        <artifactId>junit</artifactId>
+        <version>3.8.2</version>
+        <scope>test</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>net.sourceforge.stripes</groupId>
+        <artifactId>stripes</artifactId>
+        <version>1.5.7</version>
+        <scope>test</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>org.eclipse.jetty.aggregate</groupId>
+        <artifactId>jetty-all</artifactId>
+        <version>7.6.7.v20120910</version>
+        <scope>test</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>org.hsqldb</groupId>
+        <artifactId>hsqldb</artifactId>
+        <version>1.8.0.10</version>
+        <scope>test</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>tomcat</groupId>
+        <artifactId>jasper-runtime</artifactId>
+        <version>5.5.23</version>
+        <scope>test</scope>
+      </dependency>
+
+      <!-- provided dependencies -->
+      <dependency>
+        <groupId>javax.servlet.jsp</groupId>
+        <artifactId>jsp-api</artifactId>
+        <version>2.0</version>
+        <scope>provided</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>javax.servlet</groupId>
+        <artifactId>servlet-api</artifactId>
+        <version>2.4</version>
+        <scope>provided</scope>
+      </dependency>
+
+      <!-- runtime dependencies -->
+      <dependency>
+        <groupId>commons-io</groupId>
+        <artifactId>commons-io</artifactId>
+        <version>1.4</version>
+        <scope>runtime</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>nekohtml</groupId>
+        <artifactId>nekohtml</artifactId>
+        <version>0.9.4</version>
+        <scope>runtime</scope>
+      </dependency>
+
+      <dependency>
+        <groupId>taglibs</groupId>
+        <artifactId>standard</artifactId>
+        <version>1.1.2</version>
+        <scope>runtime</scope>
+      </dependency>
+    </dependencies>
+  </dependencyManagement>
+  
   <build>
     <plugins>  <!-- plugins executed with every build -->
       <plugin>
@@ -61,7 +284,7 @@
       </plugin>
     </plugins>
   
-    <pluginManagement> <!-- defines what configuration is going to be used if and
only if the plugin is used                            -->
+    <pluginManagement> <!-- defines what configuration is going to be used if, and
only if, the plugin is used                          -->
       <plugins>        <!-- ordered alphabetically by groupId (default first):artifactId
                                               -->
         <plugin>       <!-- default maven plugins have their version configured
to make the build independent of the maven version used -->
           <artifactId>maven-antrun-plugin</artifactId>



Mime
View raw message