jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Warren Post <war...@spideroak-inc.com>
Subject [SOLVED] Re: Attempting to view response data in view results tree fails
Date Wed, 26 Jun 2019 20:49:57 GMT
You put me on the right track and the problem is solved; thank you!


Specifically and per the link you provided, I uninstalled the Brew version and manually installed
the tgz direct from jmeter.apache.org. All works as expected.


I'm not sure of the cause but I do notice that the Brew version came with a lot of plugins
installed out of the box, attempting to deactivate any generated an error message on stdout,
and upon relaunching the Brew version the supposedly deactivated plugins were active again.
Now that I am on the working official version I will only install plugins on an as-needed
basis.


I thought I had searched carefully before requesting help here, but my search should have
turned up the link you provided. And in any case it should have occured to me to have first
replaced the Brew version with the official version.


Thanks again for your help,


--

Warren


________________________________
From: Felix Schumacher <felix.schumacher@internetallee.de>
Sent: Wednesday, June 26, 2019 1:54 PM
To: JMeter Users List
Subject: [EXT] Re: Attempting to view response data in view results tree fails

You might want to have a look at https://bz.apache.org/bugzilla/show_bug.cgi?id=63360

Regards
 Felix

Am 26. Juni 2019 20:58:45 MESZ schrieb Warren Post <warren@spideroak-inc.com>:
>After running a test in the GUI, I press the response data button in
>the view results tree. According to a tutorial I am following, I should
>see the response of the server I tested. Instead the view results tree
>portion of the JMeter GUI freezes, GUI elements may appear misplaced,
>and there is no apparent way to view the server's response.
>
>I installed first OpenJDK 12.0.1 and then JMeter 5.1.1 on Mac 10.14.5
>using Homebrew. I launch JMeter via a terminal. When I trigger the GUI
>problem, stdout says:
>
>Uncaught Exception java.lang.ClassCastException: class
>javax.swing.text.DefaultStyledDocument cannot be cast to class
>jsyntaxpane.SyntaxDocument (javax.swing.text.DefaultStyledDocument is
>in
>module java.desktop of loader 'bootstrap'; jsyntaxpane.SyntaxDocument
>is in
>unnamed module of loader org.apache.jmeter.DynamicClassLoader
>@2a84aee7).
>See log file for details.
>
>The final entry in jmeter.log (attached) has a timestamp that
>corresponds to triggering the GUI problem.
>
>Searching both this forum and elsewhere I can find no other reports of
>this problem, so presumably the issue is on my end. What should I be
>looking at to find and fix my problem?
>
>
>--
>
>Warren

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message