jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "glinius@live.com" <glin...@live.com>
Subject Re: Login issue when executing test on server side
Date Mon, 17 Jun 2019 13:02:34 GMT
If the issue cannot be reproduced for lesser number of virtual users (i.e. 1,
2, 20) - most probably it indicates server issue, i.e. it lacks resources
(can be checked using i.e.  JMeter PerfMon Plugin
<https://blazemeter.com/blog/how-monitor-your-server-health-performance-during-jmeter-load-test/>

), has wrong configuration of application server / database / load balancer
or the application itself is not optimized for high loads (can be checked
using  profiler tools
<https://en.wikipedia.org/wiki/List_of_performance_analysis_tools>  )

Another possible reason is that JMeter is not capable of sending requests
properly due to lack of resources or improper configuration. Theoretically
you should be able to easily simulate 200 users even using default JMeter
setup and single node assuming you  run your test in non-GUI mode
<https://jmeter.apache.org/usermanual/get-started.html#non_gui>  , however
it's better to make sure that you're following  JMeter Best Practices
<https://jmeter.apache.org/usermanual/best-practices.html>   and that JMeter
has enough headroom to properly operate.   



--
Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message