jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Podelko <apode...@yahoo.com.INVALID>
Subject Re: can't record a script
Date Wed, 05 Jun 2019 20:31:53 GMT
 Hi,
It looks like I was able to figure out proper settings. After I set all parameters properly
in system.properties:
http.proxyHost=
http.proxyPort=
https.proxyHost=
https.proxyPort=
http.nonProxyHosts=
https.nonProxyHosts=
(+certificate) I was able to record the script. Sorry, didn't get all settings properly.

Which is somewhat strange as it appears that it still fails all CONNECT static.oracle.com:443
with javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
and it doesn't appear to add any https://static.oracle.com requests to the script.

It is a smaller problem -as I am not sure if I actually want to load https://static.oracle.com
during my internal tests...

But I am not sure why it stuck before and recording now - while still can't connect.

If anybody is interested, attaching new recording.xml

Thanks,Alex
[another interesting issue is that my previous e-mail had 4 attachments, but looks like only
one got through]


    On Wednesday, June 5, 2019, 1:26:42 PM EDT, Alexander Podelko <apodelko@yahoo.com.INVALID>
wrote:  
 
 Hi,
Can't record a script anymore [JMeter 5.1.1] - for the system I recorded scripts before without
any issue before (earlier versions)... At some point (usually right after login) it just show
me an empty screen in the browser instead of landing page. 

Reverted JMeter to default configuration, disabled most FF internal requests - still the same.

Attaching recording.xml, resulting test plan, jmeter.log, and the Fiddler session for successful
login.
My current suspicion is that the system appears to start getting some resources from CDN (https://static.oracle.com/cdn/jet/v6.2.0/default/css/alta/oj-alta-min.css)
instead of local - and can't get it from there (I guess the lack of css may explain the empty
screen). That request should go through a proxy and it is https vs http of all other traffic.
I have the proxy in the command line. I tried adding proxy to system.properties and importing
JMeter certificate into FF - but it didn't help. As I don't quite see any error messages,
so not sure what is the problem. 
 Any idea? 

Thanks,Alex
    
---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org  
Mime
View raw message