jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "glinius@live.com" <glin...@live.com>
Subject Re: JMeter 4 with Java 1.7
Date Mon, 12 Nov 2018 15:44:19 GMT
According to  JMeter changelog
<https://jmeter.apache.org/changes_history.html>   the latest JMeter version
which is compatible with Java 7 is  JMeter 3.1
<https://www.blazemeter.com/blog/whats-new-jmeter-31>  

I don't think you will be able to use  JMeter 4 with Java 7 as it simply
will not compile. 

With regards to "organization" if you really need JMeter 4 you can point the
responsible persons to  JMeter Best Practices you should always be using the
latest version of JMeter
<https://jmeter.apache.org/usermanual/best-practices.html>  , moreover the
end of public updates for Java 7 was in April 2015 (>3 years ago)

Be aware that you can always download Java 8 (or higher) from OpenJDK
archives <https://jdk.java.net/8/>   or use  Java 8 Docker containers
<https://hub.docker.com/_/java/>   so you could bundle Java distribution
along with the required JMeter distribution along with the tests

  



--
Sent from: http://www.jmeter-archive.org/JMeter-User-f512775.html

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@jmeter.apache.org
For additional commands, e-mail: user-help@jmeter.apache.org


Mime
View raw message