jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Rancati <ivan.ranc...@gmail.com>
Subject Re: Java 9?
Date Fri, 03 Nov 2017 21:42:22 GMT
for what it's worth:
with Linux (Kali), Jmeter nightly 1814153 and the Oracle jdk 9.0.1 I can
open the attachment in Bug 61721 (dmcs_171_modified.jmx)
I can run the .jmx as well

best regards
Ivan

On Fri, Nov 3, 2017 at 9:34 PM, Alexander Podelko <
apodelko@yahoo.com.invalid> wrote:

>  Bug 61721 - can't open a script with Java 9
>
>     On Friday, November 3, 2017, 3:30:14 PM EDT, Philippe Mouawad <
> philippe.mouawad@gmail.com> wrote:
>
>  Hello Alexander,
> JMeter 3.3 will not work with Java9 as per release notes.
>
> Nightly build works for me with Java 9 on MacOsX with Oracle Jdk.
>
> There might be some issue in windows shell remaining.
>
> Could you file a bug and attach:
> - jmeter.log
> - info about your configuration (java version...)
> - show the resulting command line launched
>
> Thanks
>
> On Friday, November 3, 2017, Alexander Podelko <apodelko@yahoo.com.invalid
> >
> wrote:
>
> >  Nightly build as apache-jmeter-r1814153 ?
> > Getting the following error trying to open a script:
> >  2017-11-03 14:49:47,161 INFO o.a.j.g.a.Load: Loading file:
> > C:\projects\JMeter\dmcs_171_modified.jmx2017-11-03 14:49:47,162 INFO
> > o.a.j.s.FileServer: Set new base='C:\projects\JMeter'2017-11-03
> > 14:49:47,339 ERROR o.a.j.JMeter: Uncaught exception: java.lang.
> ExceptionInInitializerError:
> > null at com.thoughtworks.xstream.XStream.setupConverters(
> XStream.java:989)
> > ~[xstream-1.4.10.jar:1.4.10] at com.thoughtworks.xstream.
> > XStream.<init>(XStream.java:592) ~[xstream-1.4.10.jar:1.4.10] at
> > com.thoughtworks.xstream.XStream.<init>(XStream.java:514)
> > ~[xstream-1.4.10.jar:1.4.10] at com.thoughtworks.xstream.
> > XStream.<init>(XStream.java:483) ~[xstream-1.4.10.jar:1.4.10] at
> > com.thoughtworks.xstream.XStream.<init>(XStream.java:429)
> > ~[xstream-1.4.10.jar:1.4.10] at com.thoughtworks.xstream.
> > XStream.<init>(XStream.java:382) ~[xstream-1.4.10.jar:1.4.10] at
> > org.apache.jmeter.save.SaveService$XStreamWrapper.<
> init>(SaveService.java:82)
> > ~[ApacheJMeter_core.jar:r1814153] at org.apache.jmeter.save.
> > SaveService$XStreamWrapper.<init>(SaveService.java:80)
> > ~[ApacheJMeter_core.jar:r1814153] at org.apache.jmeter.save.
> > SaveService.<clinit>(SaveService.java:113) ~[ApacheJMeter_core.jar:
> r1814153]
> > at org.apache.jmeter.gui.action.Load.loadProjectFile(Load.java:130)
> > ~[ApacheJMeter_core.jar:r1814153] at org.apache.jmeter.gui.action.
> > Load.loadProjectFile(Load.java:102) ~[ApacheJMeter_core.jar:r1814153] at
> > org.apache.jmeter.gui.action.Load.doActionAfterCheck(Load.java:89)
> > ~[ApacheJMeter_core.jar:r1814153] at org.apache.jmeter.gui.action.
> > AbstractActionWithNoRunningTest.doAction(AbstractActionWithNoRunningTes
> t.java:45)
> > ~[ApacheJMeter_core.jar:r1814153] at org.apache.jmeter.gui.action.
> > ActionRouter.performAction(ActionRouter.java:88)
> ~[ApacheJMeter_core.jar:r1814153]
> > at org.apache.jmeter.gui.action.ActionRouter.lambda$actionPerformed$0(
> ActionRouter.java:70)
> > ~[ApacheJMeter_core.jar:r1814153] at java.awt.event.
> > InvocationEvent.dispatch(Unknown Source) ~[?:?] at java.awt.EventQueue.
> dispatchEventImpl(Unknown
> > Source) ~[?:?] at java.awt.EventQueue.access$500(Unknown Source) ~[?:?]
> > at java.awt.EventQueue$3.run(Unknown Source) ~[?:?] at
> > java.awt.EventQueue$3.run(Unknown Source) ~[?:?] at java.security.
> > AccessController.doPrivileged(Native Method) ~[?:?] at java.security.
> > ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown
> > Source) ~[?:?] at java.awt.EventQueue.dispatchEvent(Unknown Source)
> > ~[?:?] at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown
> > Source) [?:?] at java.awt.EventDispatchThread.
> pumpEventsForFilter(Unknown
> > Source) [?:?] at java.awt.EventDispatchThread.
> pumpEventsForHierarchy(Unknown
> > Source) [?:?] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
> > [?:?] at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:?]
> at
> > java.awt.EventDispatchThread.run(Unknown Source) [?:?]Caused by:
> > java.lang.reflect.InaccessibleObjectException: Unable to make field
> > private final java.util.Comparator java.util.TreeMap.comparator
> accessible:
> > module java.base does not "opens java.util" to unnamed module @554e218 at
> > java.lang.reflect.AccessibleObject.checkCanSetAccessible(Unknown Source)
> > ~[?:?] at java.lang.reflect.AccessibleObject.
> checkCanSetAccessible(Unknown
> > Source) ~[?:?] at java.lang.reflect.Field.checkCanSetAccessible(Unknown
> > Source) ~[?:?] at java.lang.reflect.Field.setAccessible(Unknown Source)
> > ~[?:?] at com.thoughtworks.xstream.core.util.Fields.locate(Fields.
> java:40)
> > ~[xstream-1.4.10.jar:1.4.10] at com.thoughtworks.xstream.
> > converters.collections.TreeMapConverter.<clinit>(
> TreeMapConverter.java:50)
> > ~[xstream-1.4.10.jar:1.4.10] ... 29 more
> >
> >
> > Thanks,Alex
> >
> >    On Friday, November 3, 2017, 2:16:54 PM EDT, Antonio Gomes Rodrigues <
> > ra0077@gmail.com <javascript:;>> wrote:
> >
> >  Hi
> >
> > Already modified
> >
> > Have you tested the futur 3.4 release  ?
> >
> > Le 3 nov. 2017 19:08, "Alexander Podelko" <apodelko@yahoo.com.invalid> a
> > écrit :
> >
> > > Hi,
> > > Would JMeter 3.3 work with Java 9? jmeter.bat can't recognize it:
> > >
> > > c:\apache-jmeter-3.3\bin>java -versionjava version "9-ea"Java(TM) SE
> > > Runtime Environment (build 9-ea+163)Java HotSpot(TM) 64-Bit Server VM
> > > (build 9-ea+163, mixed mode)
> > > c:\apache-jmeter-3.3\bin>jmeter.batNot able to find Java executable or
> > > version. Please check your Java installation.errorlevel=2Press any key
> to
> > > continue . . .
> > >
> > > I guess jmeter.bat may be modified to fix that - but will it work?
> > > Thanks, Alex
>
>
>
> --
> Cordialement.
> Philippe Mouawad.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message