jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yoel Spotts <y...@expapp.com>
Subject Re: disappearing variables
Date Tue, 28 Nov 2017 12:54:54 GMT
thanks for all the great pointers. My Jmeter script is working perfectly
now!

On Wed, Nov 22, 2017 at 4:40 PM, Yoel Spotts <yoel@expapp.com> wrote:

> thanks so much for the response! I will make sure to read those links and
> try it out. I will let you know what happens.
>
> On Wed, Nov 22, 2017 at 4:23 PM, Philippe Mouawad <
> philippe.mouawad@gmail.com> wrote:
>
>> I think issue is due to Counters config.
>> You didn't check "Track counter independently fro each user" nor "reset
>> Counter on each iteration".
>>
>>    - http://jmeter.apache.org/usermanual/component_reference.html#Counter
>>
>> I the location of JSR223 PreProcessor intentional ? It will be executed
>> for
>> every sampler:
>>
>>    - http://jmeter.apache.org/usermanual/test_plan.html#scoping_rules
>>
>> Regarding jp@gc - JSON Path Extractor, there is a core JSON Extractor in
>> jmeter:
>>
>>    -
>>    http://jmeter.apache.org/usermanual/component_reference.
>> html#JSON_Extractor
>>
>> Regards
>>
>>
>>
>> On Wed, Nov 22, 2017 at 8:51 PM, Yoel Spotts <yoel@expapp.com> wrote:
>>
>> > Apologies. Hopefully this is sufficient:
>> >
>> > https://pastebin.com/5hJeSfK2
>> >
>> > On Wed, Nov 22, 2017 at 2:38 PM, Philippe Mouawad <
>> > p.mouawad@ubik-ingenierie.com> wrote:
>> >
>> > > Hello,
>> > > Mailing list does not allow attachments.
>> > > Could you make it available somewhere else ?
>> > >
>> > > Thanks
>> > >
>> > > On Wednesday, November 22, 2017, Yoel Spotts <yoel@expapp.com> wrote:
>> > >
>> > > > I am using Jmeter 3.3 and am experiencing what can best be
>> described as
>> > > > "disappearing" variables. I have attached my jmeter script. Let me
>> > > describe
>> > > > the sequence of events with an outline:
>> > > >
>> > > > - Thread Group with X number users. For each user (thread), perform
>> the
>> > > > following:
>> > > > * Loop with a counter of 10,  each loop do:
>> > > >   * call to an endpoint
>> > > >   * capture Location response header
>> > > >   * store value of Location in variable named STATUS_X (where X is
>> the
>> > > > loop counter)
>> > > > * Loop with a counter of 10,  each loop do:
>> > > >   * call to endpoint stored in STATUS_X
>> > > >   * capture response in RESULT_X (where X is the loop counter)
>> > > > * While condition, stopping when RESULT_X for all values of X
>> indicates
>> > > > success
>> > > >   * Loop with a counter of 10,  each loop do:
>> > > >   * call to endpoint stored in STATUS_X
>> > > >   * capture response in RESULT_X (where X is the loop counter)
>> > > >
>> > > > However, what I am finding is that in the while condition, some of
>> the
>> > > > STATUS_X values are gone. The weird thing is that its inconsistent
>> > which
>> > > > ones are missing. I have inserted a Debug Sampler to track. On some
>> > > loops,
>> > > > STATUS_1 might be missing, but be present in the next loop. In a
>> > > different
>> > > > loop, STATUS_8 and STATUS_9 might be missing, and re-appear the next
>> > > loop.
>> > > >
>> > > > Any ideas what might be going on?
>> > > >
>> > > > Happy to provide any other details that might be helpful.
>> > > >
>> > > > Thanks so much in advance!
>> > > >
>> > > > Yoel Spotts
>> > > >
>> > > >
>> > > >
>> > > >
>> > >
>> > > --
>> > > Cordialement.
>> > > Philippe Mouawad.
>> > > Ubik-Ingénierie
>> > >
>> > > UBIK LOAD PACK Web Site <http://www.ubikloadpack.com/>
>> > >
>> > > UBIK LOAD PACK on TWITTER <https://twitter.com/ubikloadpack>
>> > >
>> >
>>
>>
>>
>> --
>> Cordialement.
>> Philippe Mouawad.
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message