jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harshal Kulkarni <kulkarni.hars...@gmail.com>
Subject Keystore not found
Date Fri, 31 Mar 2017 09:31:03 GMT
Hi Team -

I am trying to test the secured Web Service with Jmeter. I used below pre
processor to provide the keystore and respective information to add the
signature to the request header.

[image: Inline image 1]


But, when I am trying to replay the script, I see fault string in the
response data -

<faultcode>wsse:InvalidSecurity</faultcode><faultstring>Missing
wsse:Security header in request</faultstring>


When i tried to debug the issue, I see below message in the jmeter logs :

2017/03/30 15:49:46 DEBUG - jmeter.util.JsseSSLManager: SSL stuff all set

2017/03/30 15:49:46 DEBUG - jmeter.util.JsseSSLManager: JsseSSLManager
installed

2017/03/30 15:49:46 INFO  - jmeter.util.SSLManager: JmeterKeyStore
Location:  type JKS

*2017/03/30 15:49:46 INFO  - jmeter.util.SSLManager: KeyStore created OK*

*2017/03/30 15:49:46 WARN  - jmeter.util.SSLManager: Keystore file not
found, loading empty keystore*

2017/03/30 15:49:46 DEBUG - jmeter.util.SSLManager: JmeterKeyStore type:
class org.apache.jmeter.util.keystore.JmeterKeyStore


Can someone help me her to find out the issue?

I also tried to add the keystore properties in system.properties. But it
didnt helped out.

Is there any specific location, where I need to place the keystore file?



-- 
Thanks,
Harshal Kulkarni
M: +91 998-778-4548

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message