jmeter-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anil Gaur <anilg...@live.com>
Subject Re: Need Help-Master-Slave Issue
Date Fri, 17 Feb 2017 08:41:20 GMT
Hi found that on Master system i am getting following error.So might me this is the issue for
slave.


So can some one suggest me how to over come from this issue?


jmeter.protocol.http.control.KerberosManager: Could not log in user Loadtest4 javax.security.auth.login.LoginException:
No LoginModules configured for JMeter
at javax.security.auth.login.LoginContext.init(Unknown Source)
at javax.security.auth.login.LoginContext.<init>(Unknown Source)
at org.apache.jmeter.protocol.http.control.KerberosManager$1.call(KerberosManager.java:71)
at org.apache.jmeter.protocol.http.control.KerberosManager$1.call(KerberosManager.java:65)
at java.util.concurrent.FutureTask.run(Unknown Source)
at org.apache.jmeter.protocol.http.control.KerberosManager.getSubjectForUser(KerberosManager.java:89)
at org.apache.jmeter.protocol.http.control.AuthManager.getSubjectForUrl(AuthManager.java:276)
at org.apache.jmeter.protocol.http.sampler.HTTPHC4Impl.executeRequest(HTTPHC4Impl.java:634)
at org.apache.jmeter.protocol.http.sampler.HTTPHC4Impl.sample(HTTPHC4Impl.java:413)
at org.apache.jmeter.protocol.http.sampler.HTTPSamplerProxy.sample(HTTPSamplerProxy.java:74)
at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1166)
at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1155)
at org.apache.jmeter.threads.JMeterThread.executeSamplePackage(JMeterThread.java:475)
at org.apache.jmeter.threads.JMeterThread.processSampler(JMeterThread.java:418)
at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:249)
at java.lang.Thread.run(Unknown Source)




________________________________
From: Anil Gaur <anilgaur@live.com>
Sent: Wednesday, February 15, 2017 2:51 PM
To: JMeter Users List
Subject: Re: Need Help-Master-Slave Issue

Hi I have place CSV file on the same location for slave where the CSV file put up in master
system. But i am getting same error.

While ruining the same test plan on Mater its running perfectly but only on slave its giving
the error. Which i can find only slave server log file. on master system log i am not getting
any error.


Anil


________________________________
From: Antonio Gomes Rodrigues <ra0077@gmail.com>
Sent: Wednesday, February 15, 2017 2:41 PM
To: JMeter Users List
Subject: Re: Need Help-Master-Slave Issue

The file must be in the same directory as in Master

If it's in bin folder in master, put it in bin folfer in slaves

Antonio

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Garanti
sans virus. www.avast.com<http://www.avast.com>
Avast | Download Free Antivirus for PC, Mac & Android<http://www.avast.com/>
www.avast.com
Protect your devices with the best free antivirus on the market. Download Avast antivirus
and anti-spyware protection for your PC, Mac and Android.



Avast | Download Free Antivirus for PC, Mac & Android<http://www.avast.com/>
Avast | Download Free Antivirus for PC, Mac & Android<http://www.avast.com/>
www.avast.com
Protect your devices with the best free antivirus on the market. Download Avast antivirus
and anti-spyware protection for your PC, Mac and Android.



www.avast.com<http://www.avast.com>
Avast | Download Free Antivirus for PC, Mac & Android<http://www.avast.com/>
www.avast.com
Protect your devices with the best free antivirus on the market. Download Avast antivirus
and anti-spyware protection for your PC, Mac and Android.



Protect your devices with the best free antivirus on the market. Download Avast antivirus
and anti-spyware protection for your PC, Mac and Android.



<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

2017-02-15 15:38 GMT+01:00 Anil Gaur <anilgaur@live.com>:

> Where I have to upload the CSV file in Slave?  I m guessing BIN folder
> where my Master CSV exist?
>
>
> Anil
>
> ________________________________
> From: Antonio Gomes Rodrigues <ra0077@gmail.com>
> Sent: Wednesday, February 15, 2017 2:36 PM
> To: JMeter Users List
> Subject: Re: Need Help-Master-Slave Issue
>
> You need to upload test_dynamic.csv file in all the slaves
>
> Antonio
>
> <https://www.avast.com/sig-email?utm_medium=email&utm_
> source=link&utm_campaign=sig-email&utm_content=webmail>
> Garanti
> sans virus. www.avast.com<http://www.avast.com>
> Avast | Download Free Antivirus for PC, Mac & Android<
> http://www.avast.com/>
> www.avast.com<http://www.avast.com>
> Protect your devices with the best free antivirus on the market. Download
> Avast antivirus and anti-spyware protection for your PC, Mac and Android.
>
>
>
> <https://www.avast.com/sig-email?utm_medium=email&utm_
> source=link&utm_campaign=sig-email&utm_content=webmail>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>
> 2017-02-15 15:34 GMT+01:00 Anil Gaur <anilgaur@live.com>:
>
> > Yes i have checked the slave log and found following errors:-
> >
> > Test failed! java.lang.IllegalArgumentException: File test_dynamic.csv
> > must exist and be readable
> >
> > Can you please tell me . Do i ahve to put csv file on Slave as well? Yes
> > then please give me steps.
> > ________________________________
> > From: Maxime Chassagneux <maxime.chassagneux@gmail.com>
> > Sent: Wednesday, February 15, 2017 2:22 PM
> > To: JMeter Users List
> > Subject: Re: Need Help-Master-Slave Issue
> >
> > If your jmeter test plan use data set file , are you sure that all these
> > files are accessible on the slave node ?
> >
> > 2017-02-15 14:44 GMT+01:00 Philippe Mouawad <philippe.mouawad@gmail.com
> >:
> >
> > > Did you check slave logs ?
> > >
> > >
> > > On Wednesday, February 15, 2017, Anil Gaur <anilgaur@live.com> wrote:
> > >
> > > > Hi All,
> > > >
> > > > I am running jmeter test plan using Master and Slave.While running on
> > > Only
> > > > master than it run successful but while running from master to slave
> > then
> > > > its not running.
> > > >
> > > >
> > > > Checked the Log file and found this:-
> > > >
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.DistributedRunner:
> > Configuring
> > > > remote engine: 10.10.20.40
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.DistributedRunner:
> Starting
> > > > remote engines
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.DistributedRunner:
> Starting
> > > the
> > > > test @ Wed Feb 15 04:57:23 PST 2017 (1487163443547)
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.ClientJMeterEngine:
> running
> > > > clientengine run method
> > > > 2017/02/15 04:57:23 INFO  - jmeter.samplers.BatchSampleSender: Using
> > > > batching (client settings) for this run. Thresholds: num=100,
> > time=60000
> > > > 2017/02/15 04:57:23 INFO  - jmeter.samplers.
> DataStrippingSampleSender:
> > > > Using DataStrippingSampleSender for this run
> > > > 2017/02/15 04:57:23 INFO  - jmeter.samplers.BatchSampleSender: Using
> > > > batching (client settings) for this run. Thresholds: num=100,
> > time=60000
> > > > 2017/02/15 04:57:23 INFO  - jmeter.samplers.
> DataStrippingSampleSender:
> > > > Using DataStrippingSampleSender for this run
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.ClientJMeterEngine: sent
> > test
> > > > to 10.10.20.40 basedir='.'
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.ClientJMeterEngine:
> Sending
> > > > properties {}
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.ClientJMeterEngine: sent
> run
> > > > command to 10.10.20.40
> > > > 2017/02/15 04:57:23 INFO  - jmeter.engine.DistributedRunner: Remote
> > > > engines have been started
> > > > 2017/02/15 04:57:23 INFO  - jmeter.gui.util.JMeterMenuBar:
> > > > setRunning(true,10.10.20.40)
> > > > 2017/02/15 04:57:24 INFO  - jmeter.gui.util.JMeterMenuBar:
> > > > setRunning(false,10.10.20.40)
> > > >
> > > >
> > > >
> > > > Can any one please tell me what going on my slave beacuse I am not
> > > getting
> > > > any error.
> > > > All Slave are on same subnet.
> > > > All slaves and master firewall are disabled.
> > > >
> > > > Only Works on Master System. While executing on Slave its not
> working.
> > I
> > > > have already restarted all the slave but again same issue.
> > > >
> > > >
> > > > Regards
> > > > Anil
> > > >
> > > >
> > >
> > > --
> > > Cordialement.
> > > Philippe Mouawad.
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message